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1.  WHAT IS STATPLANET 

StatPlanet is a powerful interactive data visualization and mapping tool. It is used by many different kinds of 
organizations including UN agencies, Fortune 500 companies, government departments, NGOs, schools and 
universities to communicate, disseminate and explore data. StatPlanet is not only for adults – it is also used by 
children (ages 9 and above) to learn about the world through interactive maps. 

One of the greatest strengths of StatPlanet is that it enables also non-technical users to explore statistics through 
its user-friendly interface. Moreover, the software automates the normally complex processes of converting raw 
data into interactive maps and visualizations. This enables even non-technical users to create interactive maps 
and visualizations with relative ease. You can import your own data into StatPlanet, as well as your own maps 
(both Flash maps and ESRI shapefile maps) – or you can use the included world or USA maps. 

StatPlanet comes in different versions to cater to different needs. All versions of StatPlanet are free except for 
StatPlanet Plus, which has more advanced features such as support for large datasets. All versions of StatPlanet 
can be used both as a stand-alone application for offline use, and as a web-based application which can be 
published online. The offline version of StatPlanet Plus is free for non-commercial purposes. 

The aim of StatPlanet is to promote evidence-based decision making by improving and facilitating the 
communication and interpretation of information. StatPlanet does this by providing (i) attractive interactive 
visualizations which facilitate the interpretation of information, (ii) a user friendly interface that is accessible 
also to non-technical users, (iii) automated data visualization (including the processes of merging and 
synchronizing data from different sources), and (iv) an easy to disseminate software system which can enable 
anyone to explore and create data visualizations - regardless of technical skills, availability of Internet 
connectivity, and computer hardware or software. 

StatPlanet was conceptualized and is being developed by Frank van Cappelle since 2005. From 2008 to 2010, 
the development of a tailored version of StatPlanet was undertaken as part of the SACMEQ research 
programme at the UNESCO International Institute for Educational Planning (IIEP). StatPlanet is now a 
registered company in Australia. 

StatPlanet websites: 

• www.sacmeq.org/statplanet - StatPlanet website hosted by SACMEQ (Southern and Eastern Africa 
Consortium for Monitoring Educational Quality). 

• www.statplanet.org - StatPlanet World Bank, first prize winner in the World Bank’s “Apps for 
Development” competition in 2011. 
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2. STATPLANET SYSTEM REQUIREMENTS 

StatPlanet was designed to be usable in as many places as possible regardless of the available computers and 
infrastructure. It can be used online, through an intranet as well as offline – making it usable in places where 
there is no Internet connectivity. It is easy to disseminate due to its very small size – small enough to fit on any 
USB flash drive (USB stick) or to be sent as an e-mail attachment. The software does not require installation, so 
even those without administrator rights on their PC can run both the offline and online versions. 

StatPlanet runs in the Adobe Flash Player, which has the following minimum system requirements1. As can be 
seen in the table the system requirements are low, and any computer purchased within the past 7 years should be 
able to run StatPlanet. 

Windows® Macintosh Linux® 

Intel® Pentium® II 450MHz, AMD Athlon™ 
600MHz or faster processor (or equivalent) 

PowerPC® G3 500MHz or 
faster processor 
 
Intel Core™ Duo 1.33GHz 
or faster processor 

Modern processor 
(800MHz or faster) 

128MB of RAM 128MB of RAM 512MB of RAM, 128MB 
of graphics memory 

128MB of VRAM* 

*Recommended for GPU hardware acceleration–dependent features. Flash Player will use software mode for 
systems that do not meet the system requirements. 

 

 

 

 

                                                 
1 http://www.adobe.com/products/flashplayer/systemreqs/ 
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3. STATPLANET FEATURES AND OPTIONS 

 

 

3.1 Thematic map 

 

 

Choropleth Map 
This is the main thematic map type in StatPlanet. The map legend shows which map colors are 
associated with each data range (for example, higher values may be shaded in increasingly 
darker colors). Both the map colors and the data range can be customized (see Map legend 
below). In version 2.1, the possibility of creating qualitative or descriptive maps was 
introduced. These types of maps convey non-numerical information, such as which languages 
are spoken in different regions. 

 

 

Proportional Symbol Map 
A proportional symbol map scales symbols (usually circles) according to the indicator being 
mapped. Each symbol can represent a country or other map region. In StatPlanet the symbol 
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map is overlaid on top of the choropleth map (see above). This means that two data sets can be 
shown on the same map – one for the choropleth map and one for the symbol map. 

To show the symbol map, click the symbol icon (shown on the left) in the bottom-left corner of 
the screen. If you have bookmarked an indicator, the symbol map represents the data for the 
bookmarked indicator, whereas the choropleth map represents the data for the selected 
indicator. (If the bookmarked indicator is currently selected, both the symbol map and the 
choropleth map represent the bookmarked indicator).  

  Select country on the world map 

• Mouse over a country: Moving the mouse over a country on the world map brings up a 
popup containing information about that particular country for the selected indicator (as 
well as the bookmarked indicator, if there is one). In addition, the country data for all 
indicators in the current category is shown in the indicators panel. 

• Click on a country: You can select a country by clicking on it in the map. This will 
highlight the country in the graph, and can also be used to define a custom region. See 
also the country selection panel. 

  Map legend 

Map colors: Clicking on any of the colors in the legend will bring up a color selection panel. In 
this panel you can change both the colors (either Sequential or Diverging color schemes), as 
well as the number of color classes (between 3 and 9). The color schemes are from the Color 
Brewer website (http://colorbrewer2.org/), which is an excellent resource for more information 
on selecting map colors. 

Data range: To adjust the data range of the map legend, click on the top or bottom value. Use 
the popup to increment or decrement the value, or enter a whole new value. The intermediate 
values will be adjusted automatically. 

Custom maps (national / regional / state maps etc.) 

You can use StatPlanet Map Maker to insert your own maps, using the included map template 
(map.fla). This requires the Adobe Flash software. (See: 5. Importing a map into StatPlanet) 

 

 

Save/export (StatPlanet Plus only) 
You can find the save/export button in the bottom-left corner of the screen. This button enables 
you to save the current map or graph as an image, or download the data as a CSV file. 

To change the image type, size or quality, use the options panel. This feature is only available in 
the online version on the StatPlanet website. However, it is possible to save an image of a map 
produced with your own data if you download StatPlanet Map Maker. You need to open 
StatPlanet in the directory 'Offline', click the icon shown on the left, and take a ‘Print Screen’ 
(Prt Scr button on the keyboard). This saves the contents of the screen, so that it can be pasted 
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in an image editor or document.  

Please include a reference to StatPlanet if you are publishing the image. 

 

 

Map navigation controls:  

The map zoom controls are normally hidden from view. Move the mouse towards the bottom-
right of the screen to make them appear. 

• Zoom: You can zoom in and out of the map using the 'zoom in' and 'zoom out' buttons, 
or by dragging the zoom slider up or down. If your mouse has a scroll wheel, you can 
also use this to zoom in and out.  

• Moving the map: click and drag the map with the mouse to move it to a new position. 
• Restore map position: the button shown on the left restores the map to the original 

coordinates for the selected region.  

3.2 Indicators panel 

 

 

Select category 
Use the drop-down menu in the top of the indicators panel to select a new category (online 
version only). 

 

 

Select regions  
Use the drop-down menu in the top of the indicators panel to select and zoom into a different 
region, such as 'Africa' or 'Europe'. It is also possible to select countries to define a custom 
region (see Country selection panel). 
 

 

 
 

  

Indicator bars 
The bars are scaled in proportion to the maximum value of that particular indicator for all 
countries in the selected region. For example, if the value for country X is 20 and the 
maximum value for all countries is 100, the bar will be scaled at 20%. 
 

 

 

Bookmark indicator  
Click the 'star' button in the indicators panel to bookmark the selected indicator. The 
bookmarked indicator will stay even when you switch to another category. This allows you 
to (i) create scatter plot graphs, (ii) compare the bookmarked indicator with indicators from 
other categories, and (iii) compare two indicators through the choropleth map (representing 
the selected indicator) and the proportional symbol map (representing the bookmarked 
indicator). 

  Indicator definitions  
If a definition exists for an indicator, the definition will appear in a popup when moving the 
mouse over the indicator. The definition only shows for the indicator which is selected or 
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bookmarked. 

3.3 Graph panel 

 

 

Bar chart  
Click the 'graph' button in the bottom-left corner of the screen to open or close the Graph panel. 
You will find the same graph button in the graph panel. Use this button to switch between 
horizontal and vertical bar charts. 
 
Use the "sort" button to sort the graph from lowest to highest, highest to lowest, highest to 
lowest starting in the middle, or alphabetically. 

 

 

Time series 
In the top left of the Graph panel (see "Bar chart" above) you will find the time series button. 
When you click on this button, a list of countries appears which you can add to the time series 
graph. Click on a country to add it to the graph, and click on it again if you wish to to remove it. 
(See also Country selection panel below). 

Use the "sort" button to sort the time series labels. 

 

 

Scatter Plot 
In the top left of the Graph panel (see "Bar chart" above) you will find the scatter plot button. 
Clicking on the button will automatically use the selected indicator as the x-axis variable. You 
need to select a second indicator as the y-axis variable. 

The x-axis and y-axis variables can be selected in the Graph panel (see below), or in the 
Indicators panel (see Bookmark indicator  above). 

Press the ‘play’ button to see an animation of changes over time, with each bubble (point) 
moving to the corresponding x and y positions (depending on whether data is available for each 
time interval). If ‘Show trails’ is selected (next to the play button), each bubble will leave a trail 
to mark previous positions over time. 

Clicking on a scatter plot bubble will display the associated label. They can also be repositioned 
through ‘drag and drop’, by right-clicking and selecting 'move text labels or map points'. 

A third indicator can be visualized through the bubble size parameter. This indicator can be 
selected through the drop-down above the scatter plot. The bubble size follows the formula: 
value / maximum value.  

 

 

Select x-axis / y-axis indicator 
Click on the x-axis or y-axis label, then select an indicator from the drop-down menu. 

Use the drop-down menu in the top of the graph panel to change the scale of the 'bubbles' 
according to a selected indicator. 
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Use the 'options' icon in the graph panel to show or hide the trendline. Move the mouse over the 
trendline to see the slope and trendline equation. 

 

  

Adjust graph size 
To change the graph size, move the mouse to the sides or corners of the graph panel until you 
see the cursor change to look like the one shown on the left. Click and hold down the left mouse 
button, then drag the panel to the size you want . Release the mouse button once you have the 
right size. 

 Adjust graph scale 
The graph scale can be adjusted by clicking on the top or bottom graph values. The value can 
then be edited in the popup panel. 

3.4 Options panel 

 
Click the 'options' button in the bottom-left corner of the screen to open the options panel. 

  

Map:   

• Map colors: map background, map borders, map text color, map text outline color, etc.; 

• Map text size; 

• Map symbol size (proportional symbol map symbols); 

• Map legend - estimate best value distribution: adjust the values so that there is a more 
equal distribution of countries for each color class. This will usually result in a map with 
a better distribution of colors. If this is switched off, the value range for each color class 
will be set at equal intervals based on the highest and lowest value in the data range. 

• Map legend - show maximum & minimum values 

• Map legend colors. 

Graph/Chart:   

• Graph colors: background, bar & scatter points, scatter point borders; 

• Graph text size; 

• Transparency level of graph area (bars / bubbles); 

• Size of bubbles (scatter plot graph); 

• Bullet graph. 
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General options:  

• Animation duration; 
• Decimal places shown; 
• Adjust the map/graph scale: StatPlanet automatically adjusts the map and graph scale 

to suit the data set. However, in some cases you may wish to keep it fixed, for example if 
you made some changes to it yourself. You can set (or prevent) the automatic updating of 
the map/graph scale on (i) changing indicator, (ii) changing region, (iii) changing year. 
The default setting is for StatPlanet to adjust the scale when changing indicator or region, 
but not year.  
If you have chosen to not have the map scale updated, the map legend has a shortcut 
which you can use to 'refresh' the map legend at at any time for the current indicator, 
year and region:   

 

Save/export map or graph: (online version only) 

• Set the image type: PNG or JPEG 
• Change the image size as % of original 
• Change the image quality (for JPEG images only) 

3.5 Data table panel 

 

Click the 'table' button in the bottom-left corner of the screen to get a data table of the selected 
indicator. If an indicator has been bookmarked, the data for both the bookmarked and selected 
indicator will be displayed. The table also shows the mean, standard deviation and range. 

 

Save / Export table (StatPlanet Plus only) 
Save the table as a .CSV file, which can be opened by most spreadsheets (such as Excel). You 
can find the save table button in the top-right corner of the table panel. 
 

 

Copy table 
The offline version of StatPlanet does not allow you to save the data as a file. Instead, you can 
copy the entire table into Excel using the 'copy' button, and then 'paste' it in Excel. If you do not 
have Excel, you can also do the following: (i) paste the data into a basic text editor such as 
Notepad, (ii) save the document as 'data.html', (iii) open the file using your Web Browser. 

3.6 Selecting countries 

Countries can selected in various ways. An efficient way of finding and selecting a country is through the 
country selection panel, as explained below. However, a country can also be selected by clicking on it in the 
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world map, in the data table panel, or in the bar chart or scatter plot graph. In each case the country will be 
highlighted in all of these StatPlanet components. 

 

Click the 'select' button in the bottom-left corner of the screen to get a list of countries. Then 
click to select the countries you wish to show on the map or in the graph panel. To narrow down 
the list of countries, select a region from the drop-down menu in the top-right corner of the 
screen. You can also press the first letter of a country name to quickly jump to a country in the 
list. 

 

 

Select button 
Press the Select button to confirm your selection. Any variables which are not selected will be 
removed from view.  
Note: for the time series graph, there is no need to press this button as the countries will appear 
in the graph panel as soon as you click on them. 
 

 

 

Deselect All button 
Press the Deselect All button to clear your selection. 
 
 

 

 

Refresh button 
The Refresh button . It only appears after you have clicked the Select button. 
 
 

 

 

Remove countries 
To remove countries, select the countries you wish to remove and press this button.  

 

3.7 Time slider 

 

Use the slider or click on the arrow buttons to change the year. Click on the play button to show changes over 
time as an animation, starting from the beginning. The animation speed can be set in the Options panel. 

3.8 Interface options 

 

View panel 

Move the mouse over the 'View' button in the bottom-left of the screen to see various options 
for showing or hiding map & graph elements, and other StatPlanet components. 
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• Show or hide country/region names on the map or graph (country names can be 
shown in full, in abbreviated form or as ISO3 codes); 

• Show or hide country statistics on the map or graph (country statistics can only be 
shown on the horizontal bar chart); 

• Show or hide the map popup and its components - bar chart, indicator and statistic; 
• Show or hide various panels. 

  

Shrink / enlarge panels: Use the buttons shown on the left to shrink or enlarge the 
StatPlanet panels. This may be useful for space management when you have several 
panels open at the same time, or to focus in on certain areas. 

  

Minimize / maximize panels: Use these buttons to minimize or maximize the panels. 
The indicators panel has a special minimized state in which indicators can still be 
selected. 

 

Adjust graph panel size 
Drag and drop the graph panel borders to adjust the size. 

  

Fullscreen: Click on this button in the bottom-left of the screen to either switch to 
fullscreen mode, or go back to normal panel mode. 

 

Additional notes:  

• When switching categories, StatPlanet will remember which year was selected and check if data exists 
for this year in the new category. If there is no data for this year, it will select the year closest to the 
previously selected year for which data is available in the new category. 

• When switching maps (e.g. world map to country map, or from regional map to district map), StatPlanet 
will check if the same category and indicator exist in the new map. If it cannot be found, the first 
category/indicator in the data set will be selected. 
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4. IMPORTING ESRI SHAPEFILE MAPS 

These are instructions for StatPlanet Plus.  
For StatPlanet Lite, see http://www.sacmeq.org/statplanet/StatPlanet-lite.html. 

Instructions for loading your own ESRI shapefiles into StatPlanet: 

1. Go to the folder containing the shapefile version of StatPlanet, then open the folder 'map'. 

2. Remove the included example shapefiles (map of Indonesia), and copy your own shapefiles here. 
Please note that there are two map folders in “Shapefile_map_(ESRI)”  to which you need to copy your 
map files: 

• \map     (for the offline version) 

• \web\map   (for the web version)  

3. Rename your map files (e.g. “mycountry.shp” and “mycountry.dbf”) to “map.shp” and “map.dbf” 

4. Open the StatPlanet_data_editor file. Click on the button 'Setup shapefile' (in the top-left, macros need to 
be enabled). 

5. Select your “map.dbf” file in the map folder, and follow the instructions. Make sure that the ‘ID’ column 
is either alphabetical (a-z) or alpha-numeric (a combination of alphabetical and numeric characters such 
as “dis29”). Purely numerical IDs or special characters such as ē ạ & / - may cause problems in loading 
the map.  If you do not have a suitable ID column, you could use software such as Open Office Calc to 
edit the “map.dbf” file and create/edit an ID column. Open Office Calc is free software 
(http://www.openoffice.org/). 

6. Run StatPlanet to see the results with the included sample data. 

You can now start importing or inserting data for your map, but first you may wish to modify the map position 
and add text labels. 

Map positioning: 

To change the position and size of the map, move the mouse to the bottom-right of the screen to see the map 
zoom controls: 

• Zoom: You can zoom in and out of the map using the 'zoom in' and 'zoom out' buttons, or by dragging 
the zoom slider up or down. If your mouse has a scroll wheel, you can also use this to zoom in and out. 

• Moving the map: click and drag the map with the mouse to move it to a new position. 

Once the map is in the right position, right-click and select 'Copy map coordinates'. In the StatPlanet Data 
Editor, go to the sheet 'Map regions', select the cell below 'X'. Then paste the coordinates here. 
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Text labels: 

1. To show the text labels for the map, click on ‘Show text labels’ in the StatPlanet Data Editor (sheet 
Import, below the Save button).  

2. Click on “Save data” and open StatPlanet to see the results. It is likely that the position of some or all of 
the text labels will need some adjusting.  

3. To adjust the position of the text labels, right click anywhere in StatPlanet and select ‘Move text labels 
or map points’ in the menu. Click on any of the text labels to drag them to a new position. 

4.  Once you have finished moving the text labels, right click and select ‘Copy text label coordinates’ in 
the menu. 

5. In the StatPlanet Data Editor, go to the sheet ‘Settings’. Select the cell next to ‘Text label coordinates’, 
and paste the coordinates here. (You may also wish to modify other settings in this sheet, such as the 
text font size.) 

6. Click on ‘Save settings’ (or alternatively, ‘Save data’ in the Import data screen). The coordinates have 
now been saved for when you next open StatPlanet.  

7. In the sheet ‘Settings’, you can also change additional settings such as the font size of the text labels. 

Finding a map: 

The following are useful websites for finding free shapefiles (regional / administrative boundaries maps).  
Note that you need to download the boundary files in the ".SHP" format. 

• Map Library - http://www.maplibrary.org/  - Public domain maps for most countries in the world. Maps 
are not guaranteed to be error free and up to date. 

• UN SALB - http://www.unsalb.org/ - Second Administrative Level Boundaries data set project. These 
maps are free but copyright rests with the UN. The maps are validated by the National Mapping 
Agencies (NMA) of each UN Member State. 

•  US Census Bureau - http://www.census.gov/geo/www/cob/bdy_files.html - USA County and District 
Cartographic Boundary Files. 

• ArcGIS map resources - http://resources.arcgis.com/content/data-maps/10.0/world 

• Stanford University map resources - http://www-sul.stanford.edu/depts/gis/web.html 

 
Instructions for loading shapefiles without using Excel: 

1. Copy your map shapefiles as explained above. 

2. Copy and paste the country IDs from the map.dbf file to replace the existing ones in the file data.csv. 
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3. Copy and paste the country names from the map.dbf file to replace the existing ones in the bottom of the file 
settings.csv. 

4. Copy the ID column header name, and paste it next to 'DBF-ID' in the file settings.csv. 

Note: The ID column may not contain spaces or symbols, and should have unique values only. 

 
GIS Shapefile Reader - Source Code 

The source code for reading the shapefiles is included in the directory SHPreader. It can be compiled to the file 
SHPreader.swf, which is read by StatPlanet. 

The code was written by Edwin van Rijkom under the LGPL license, with some additions by Andy Woodruff, 
and some slight modifications for use in StatPlanet. 

If you wish to change the names of the map files being read, you can change this in SHPreader.as, and publish it 
as SHPreader.swf through the file SHPreader.fla. 

For more information, see: http://shp.riaforge.org/ 
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5. ADDING OR IMPORTING DATA 

5.1 Basic steps for adding data – country-level data example 

Note: to add your own data you need to download StatPlanet Map Maker, StatPlanet Plus or StatPlanet Lite: 
http://www.sacmeq.org/statplanet. 

 

1. 

 

Download Download StatPlanet Map Maker and extract the files to your computer. 

2. 

 

Open In the folder 'World_Map', open StatPlanet_data_editor. Make sure macros 
are enabled. Press the 'Clear data' button to remove the example data. 

3. 

 

Import  Press the Import data button and select a file containing data you wish to 
import. You can also add data manually using any spreadsheet software. 

4. 

 

Save Press the 'Save data' button. This saves the data to the file data.csv. 

5. 

 

View Click on StatPlanet.exe  to view the results. 

6. 

 

Publish Copy the contents of the folder 'Web' to your website to publish it online. 

 

 
To publish StatPlanet Map Maker online, all you need to do is to upload the contents of the folder Web to the 
website (web-server). This folder contains the following files: 

• StatPlanet.html   (the webpage which displays your interactive map) 

• StatPlanet_small.html (alternative with smaller map embedded inside a webpage) 

• StatPlanet.swf   (file which shows loading progress) 

• content.swf   (the actual software) 

• settings.csv   (settings in comma-separated values format) 

• data.csv    (data in comma-separated values format) 

• swfobject.js (required to run ‘Flash’ content) 

Contents of StatPlanet_Map_Maker.zip 

• User Guide (User_Guide_StatPlanet.pdf) 

• StatPlanet Map Maker Software License (License_Terms.pdf) 

• World_Map 
- Create interactive maps using the included World Map. 
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• USA_Map 
- Create interactive maps using the included USA Map. 

• Custom_Map 
- Design or import a map using the map template (map.fla). 
(requires Adobe Flash CS3 or higher) 
- Includes an example map (map_example.fla), a province map of Kenya. 

Enable macros in Excel: 

 

 

5.2 Importing data 

Using the included StatPlanet Data Editor, it is possible to import data automatically. The Data Editor is Excel-
based, so data can be imported from many different file formats (including CSV, TXT, XLS, XLSX, DBF and 
HTML).  

The Data Editor automatically recognizes the structure of the data in the file being imported. It also recognizes 
the vast majority of the many possible variations of country names (in the world map version of StatPlanet). 
The import should therefore succeed in most cases without having to make any changes to the data file. In case 
of problems, see “troubleshooting” below. 

The Data Editor uses the names in the Excel sheet ‘Import names’ and looks for corresponding names and 
statistics in the data file (in the world map version, this sheet contains country names, but it can also contain for 
example region names or district names, depending on the map used). The Data Editor automatically 
restructures the data in the format that is accepted by StatPlanet.  

When you open StatPlanet_Data_Editor.xls you will normally get a message asking you whether you wish 
to enable macros. The message depends on the version of Excel. 

• Excel 2007 or newer: In the top of the screen, next to 'Security Warning', click the button 
'Options'. Select 'Enable this content' and click on 'OK'. 

• Older versions of Excel: Select 'Enable macros' in the popup window. 

If you do not receive this message, the macro security level in Excel is set to high. Follow the instructions 
below to change the security level to a lower setting. 

• Excel 2007 or newer: Click the Microsoft Office Button (top-left) and click Excel Options. In the 
Popular category, check 'Show Developer tab in the Ribbon' (if it is not already checked). Click on 
'OK', then select the Developer tab. Click on 'Macro security' (on the left). Select 'Disable all 
macros with notification'. 

• Older versions of Excel: In the Tools menu, go to -> Macro -> Security. Change the security level 
to Medium. 
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A criterion for the import to be successful is that any country name only appears once in the data file being 
imported. Also note that StatPlanet sees a "dot" as the decimal separator. 

Importing HTML or PDF files 

• HTML: To import data from a web-page, simply save the web-page and import it like any other file. If 
the import fails, it could be that the import/map/country names and statistics are too far down the page. 
In this case, open the file in Excel, and remove the rows up to the point that the data starts. Then import 
the file again. Alternatively, copy and paste the tables in the web-page into a new Excel document. 

• PDF: Tables in PDF files can usually be copied and pasted into an Excel file. Select (highlight) the table 
with the mouse, right-click and select “Copy as Table” or “Save as Table” from the menu. See also this 
helpful guide from McGill University: 
http://www.library.mcgill.ca/edrs/services/publications/howto/pdftoxls/pdftoexcel.html 
 
as well as this free tool to convert a PDF to an Excel file: 
http://www.pdftoexcelonline.com 

Names not recognized 

Names of map regions in the data file which are not recognized are displayed once the import is complete. For 
example, if in your data file the country ‘Afghanistan’ is indicated with the abbreviation ‘Afg', this abbreviation 
will not be recognized by the data editor. To fix the problem, go to the Excel sheet 'Import names' and add ‘Afg’ 
in an empty cell below the corresponding country - ‘Afghanistan'. You can use the same approach for other 
headers in your data set so that the import macro can correctly identify them. Then, run the import macro again 
to import the data correctly. 

Note that the import macro removes spaces in the sheet “Import names” and converts special characters (e.g. 
"é") into regular characters (e.g. "e") during the import. This allows for a wider range of country name spellings 
to be detected. Whether the names in your file use upper or lowercase does not matter. The world map version 
recognizes English and French country name spellings and a number of variations of these spellings. Automatic 
data importing has been successfully tested with many different sources of data with different data structures 
and country name variations, including the CIA Factbook, Ethnologue, IMF, ITU, Nation Master, OECD, UBS, 
UIS, UNAIDS, UNDP, UNESCO, UNICEF, UNSTATS, WHO and the World Bank. 

The Data Editor is registered as an open source project on SourceForge and any contributions or improvements 
you make to the software are very welcome. (https://sourceforge.net/projects/statplaneteditr/). 

5.3 Troubleshooting 

If you have saved your data but it cannot be read by StatPlanet, most likely there is a problem with the data structure. 
Please see point 4 below to see how to structure data by year (or other time point). Data should start with the more recent 
time point. Also make sure that the indicators listed for each year are exactly the same, and are listed in the same order. 

If the import fails, check your data file for the following issues: 
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1. Spelling of names: If the spelling of any of the country/map/region names cannot be identified, the 
corresponding data will not be imported. See “Names not recognized” above for more information on how to 
resolve this problem. 

2. Names appear more than once: If the same country/map/region names appear more than once in your data file, 
the import macro will only import the data associated with the first one.  
 
This structure will not be imported correctly: 

Country Dimension High Medium Low 
Afghanistan A 6 3 2 

 
B 7 5 2 

Albania A 9 6 3 
B 12 5 2 

Algeria A 11 5 1 
B 21 11 9 

Andorra A 15 14 12 
B 14 11 10 

 

 
This structure needs to be re-arranged with one country/map/region name per row, as shown below (alternatively, 
it may be easier in some cases to split the data into several files and import them separately). 
 
This structure will import correctly: 

Country A - High A - Medium A - Low B - High B - Medium B - Low 
Afghanistan 6 3 2 7 5 2 
Albania 9 6 3 12 5 2 
Algeria 11 5 1 21 11 9 
Andorra 15 14 12 14 11 10 

 

 
3. No year indicated in the data file, or cannot be detected: 

All indicators are arranged according to year. You need to add the year to your data set as the header of a row or 
column (depending on how your data is structured). Alternatively, you can import the data and add the year 
afterwards. The data needs to be structured as follows (see for example the structure of the sample data in 
StatPlanet_data_editor.xls): 
 

• Group (sort) your indicators according to year. Insert a new row above each group of indicators. In this 
new row add the year in the YEAR column. Leave the neighbouring cell in the INDICATOR column blank; 

• Note that the YEAR column should be blank in the cells next to the indicators: 
 

YEAR INDICATOR  
2001 

indicator1 
indicator2 

2000 
indicator1 
indicator2 
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4. Decimal point: StatPlanet reads a "dot" as decimal separator (for example 0.75). Avoid using commas, spaces or 
other symbols in numbers to ensure that they are read properly by StatPlanet. 
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6. CUSTOMIZING STATPLANET 

6.1 General settings and customizations 

General settings for customizing StatPlanet can be found in the Excel sheet Settings. After making any changes 
to the settings, press the button Save Settings. You can try out many of the settings ‘live’ in StatPlanet through 
the general options panel and the map legend options panel.  

In the Excel sheet Settings, the various settings to be edited are the yellow highlighted cells in column C. In 
some cases, the checkboxes and dropdown menus in column D can be used to more easily change the setting in 
the corresponding cell in column C (for example, click on a checkbox to change a setting from ‘TRUE’ to 
‘FALSE’). 

See also the next section for customizing StatPlanet at an indicator or category level (for example, specify 
different map colors for different indicators). 

Below are the settings which may require additional explanation: 

• Modify map, graph or interface colors 

Virtually all the colors used in StatPlanet can be customized and there are over 40 color settings. 
Additional color settings can be specified at the indicator level (see the next section for more details). 
Colors are specified using hex (hexadecimal) color code, consisting of the characters ‘0x’ followed by 
six digits or characters (e.g. 0xFFFFF for white). Hex codes can be found in commonly used design 
software such as Adobe Dreamweaver. Colors and corresponding hex codes can also easily be found 
online. 

• Show / hide interface components 

Use the options in this section to show or hide the various panels, icons and other components in order 
to customize the StatPlanet interface. 

• View menu options 

The view options in this section are identical to those in the ‘view menu’ inside StatPlanet, which 
appears when selecting the ‘view’ icon in the bottom-left of the interface. 

• Add text labels and position the text labels on the map 

Please see one of the chapters on creating a custom map (either the chapter on importing ESRI shapefile 
maps, or the chapter on using the Flash map template). 

• Add a map title  

Under ‘Map options’, ‘MAP-TITLE’, insert the text for the map title. The procedure for relocating the 
map title is the same as for relocating any other text labels on the map: (i) right click anywhere in 
StatPlanet and select ‘Move text labels or map points’ in the menu; (ii) drag the map title to a new 
position; (iii) right click and select ‘Copy text label coordinates’ in the menu; (iv) in the StatPlanet Data 
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Editor, go to the sheet ‘Settings’. Select the cell next to ‘Text label coordinates’, and paste the 
coordinates here. 

• Multiple map layers 

Under ‘Map options’, setting the value of ‘MAP-ND-TR’ to ‘TRUE’ makes map areas with no data 
transparent. This enables StatPlanet to deal with multiple map layers (i.e. representing changing map 
boundaries). For example, your map may have three map layers – 1, 2 and 3 – representing boundaries 
in three different time periods. Inserting data for one map layer would make this layer visible, and 
having no data for the remaining map layers would make them invisible.  All the map regions need to 
have a unique ID, so they can be treated independently. For example, a province in map layer 1 may also 
be present in map layer 2 but with different boundaries; this province in map layer 2 requires a unique 
ID (do not use the same ID as the one used for this province in map layer 1). In the StatPlanet Data 
Editor, there needs to be separate columns for these map regions. 

An example of a map with two map layers is included in the Custom_Flash_Map folder. The example 
can be viewed in the folder “Web_2layers_example” (by opening StatPlanet.html in your web browser). 
If you move the time slider to “2010”, the three western provinces of Kenya (in map layer 1) become 
merged into one ‘hypothetical’ province (in map layer 2). This was achieved through the following 
steps: 

1. A new map layer “map2” was added in the Flash file ‘map_example_2layers.fla’. This layer 
contains the hypothetical new western province (a merge of the three actual western provinces). 
It is given the instance name (ID): 
  WESBIG 

2. A new borders layer “borders2” was added. This layer contains the borders for the new map 
region. It needs to be given the same instance name, with the letter ‘b’ (for border) added, i.e.: 
  WESBIGb 

3. A new borders layer “borders1” was added to define the borders separately for the three western 
provinces that become the new big western province. This is required to hide these borders when 
the second map layer is shown (normally there is just one border for the whole map, the borders 
are not defined separately for each map region – in this case, there is still one border symbol for 
the whole map but the western borders are removed). As above, the borders need to be given the 
same instance names as for the corresponding map regions, with the letter ‘b’ added. In this case, 
the borders are given the following names: RIFb, WESb and NYAb (corresponding to map 
regions RIF, WES and NYA). 

4. The new map region is added to the StatPlanet Data Editor. It is given the name ‘Western Big’ in 
the sheet ‘Import’, and a corresponding ID ‘WESBIG’ in the sheet ‘Data’. 

5. For the year 2010, data is removed for the provinces Nyanza, Riftvalley and Western, so these 
provinces will become invisible when the time slider goes to 2010. In the same year, data is 
added for the province Western Big, so this province will become visible in 2010. 
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6.2 Customizations at category & indicator level 

In StatPlanet_Data_Editor.xls, there are several columns which can be used to define optional parameters. The 
different columns and their usage is explained below. 

 

• Data source 
The source of your data can be specified for each indicator, or for all indicators in a category (in 
StatPlanet Plus, you can have multiple categories and sub-categories of data). The source is indicated in 
the “SOURCE” column. To specify the source for the entire category, insert the source in the first row 
of the category (the same row as the first year in the series). To specify the source for an indicator, insert 
the source in the same row as that indicator. 
 
You can choose to use HTML code if you want to add a link to the source website, in the following 
format:  
 
<a href='http://www.mysource.com'>My Source</a>.  
 
* Important – please note:  

o In the HTML code above, you need to use single quotes ( ' ' ) rather than double quotes ( “ ” ). 

o The links do not work if you run the web version offline (the Flash platform does not allow this 
for security reasons). The links will work only once the files are online. If you wish to use or test 
the links offline, please use the desktop version. 

• Indicator description and unit 

o Description: Add a description for each indicator in this column, which will appear as a popup in 
StatPlanet when moving the mouse over the indicator.  

o Unit: Add the unit for the indicator, for example ‘%’. 

o As noted above, these only need to be added for the list of indicators below the first year in the 
series. If you have two or more indicators with the same description, you only need to enter the 
description once. For the other indicators, instead of a description enter the Excel row number (in 
the sheet ‘Import’) where the description you want to re-use is located 

• Map legend, labels and colors 

In this column you can customize the map legend for each indicator. It is possible to customize the map 
legend values (either text or numbers), colors, as well as the number of color categories. 
 

IMPORTANT : CUSTOMIZATIONS, SUCH AS AN INDICATOR DESCRIPTION, SHOULD ONLY BE 
SPECIFIED FOR THOSE INDICATORS IN THE FIRST (OR HIGHEST) YEAR. THEY DO NOT NEED 
TO BE REPEATED FOR ALL YEARS IN THE SERIES. 



22 

The map legend can be customized in StatPlanet itself, and then copied and pasted into the data file. In 
StatPlanet, select the indicator for which you wish to customize the map legend. Then click on any of 
the colors or values inside the map legend panel in the bottom-left corner to customize the map. Once 
you are satisfied with the map legend you have just customized, right-click anywhere inside StatPlanet 
and select ‘Copy map legend’ from the menu. Open the StatPlanet_Data_Editor file. Select the cell 
below the column header ‘MAP’, in the corresponding indicator row (for which you customized the map 
legend). Select ‘paste’ to insert the custom map legend. If there is data for multiple years, this only 
needs to be pasted in the row for the first year in the series. Click on ‘Save data’ to see the results the 
next time you open StatPlanet.  

More details on customizing the map legend, including how to create a qualitative map, are provided 
below. If you wish to create a qualitative map legend (based on categories such as ‘high’, ‘medium’, 
‘low’), rather than a quantitative legend (based on numeric value ranges), you need to follow the 
approach described in (iv) or (v) below. 

(i) Map legend with custom values  

� Use the following format to specify the values for the map legend, as well as the number 
of color classes: 
0=[value0] 1=[value1] 2=[value2] 3=[value3] 4=[value4]  
etc. 

� Example 1a: A legend with 4 color classes: 
0=[55] 1=[40] 2=[20]  

� Example 1b: A legend with 5 color classes: 
0=[70] 1=[65] 2=[60] 3=[55] 

                                                                            Map legend for Example 1b: 

With max / min values 
hidden 

With max / min values 
shown 

> 70 70 - max value 

65-70 65-70 

60-65 60-65 

55-60 55-60 

< 55 min value – 55 

 

(ii)  Map legend with custom colors 

� Use the following format to specify the colors for the map legend, as well as the number 
of color classes: 
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0=[color0] 1=[color1] 2=[color2] 3=[color3] 4=[color4]  
etc. 

� Example 2: A legend with 4 color classes: 
0=[0x238B45] 1=[0x66C2A4] 2=[0xB2E2E2] 3=[0xEDF8FB] 

 

(iii) Map legend with custom colors and values 

� Use the following format to specify the colors for the map legend, as well as the number 
of color classes: 
0=[color0][value0] 1=[color1][value1] 2=[color2][value2] 3=[color3][value3] 4=[color4] 
 
Note that this format is slightly different from the previous ones, because 5 colors are 
specified (colors 0 to 4) but only 4 values (values 0 to 3). As illustrated in example 1b 
above, a legend with 5 color classes requires only 4 values to be specified (a legend with 
4 color class requires only 3 values, and so on). 

� Example 3: A legend with 4 color classes and custom values: 
0=[0x2171B5][70] 1=[0x6BAED6][60] 2=[0xBDD7E7][50] 3=[0xEFF3FF] 
 

(iv)  Map legend with custom colors and labels 

� To specify text labels (instead of number values) in the map legends, use the same 
approach as described in (iii) above, but add a third parameter containing the text. For 
example: 

� Example 4: A legend with 4 color classes, custom values and custom labels: 
0=[0x2171B5][70][Very high] 1=[0x6BAED6][60][High] 2=[0xBDD7E7][50][Medium] 
3=[0xEFF3FF][Low] 
 

(v) Qualitative (descriptive) map legend 

� If you data set is categorical, e.g. languages spoken around the world (English, Spanish, 
etc.), you need to insert a qualitative map legend. Instead of value ranges, your map 
legend assigns a category number to each category you wish to display, starting from 0. 
In the example below, 5 categories are defined (0,1,2,3,4): 
 
0=[color0][label0] 1=[color1][label1] 2=[color2][label2] 3=[color3][label3] 
4=[color4][label4] 
etc. 

Countries then need to be assigned their corresponding category number. For example, if 
‘Afghanistan’ belongs to category 0 (label 0 and color 0), it should be given the value ‘0’. 
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� Example 5: A legend with 8 color classes: 
0=[0x377EB8][Arabic] 1=[0xE41A1C][Bengali] 2=[0x4DAF4A][English] 
3=[0x984EA3][Hindi] 4=[0xFF7F00][Mandarin] 5=[0xFFFF33][Portuguese] 
6=[0xA65628][Russian] 7=[0xF781BF][Spanish] 

� Map legend for Example 5: 

Color Label 

0x377EB8 Arabic 

0xE41A1C Bengali 

0x4DAF4A English 

0x984EA3 Hindi 

0xFF7F00 Mandarin 

0xFFFF33 Portuguese 

0xA65628 Russian 

0xF781BF Spanish 

 
 

• Graph axis range 

If you wish to use your own maximum and minimum values for the graph, you can set them in the 
“GRAPH” column. Specify the minimum / maximum values in parentheses in the format: [min-
value][max-value] 
 
For example, for a minimum value of 0 and a maximum value of 80, enter the following: 
 
[0][80] 
 
You can also specify the color of the graph in the format [color-code], for example: 
 
[0x78C679] 

To specify minimum / maximum values as well as color, use the format [min-value][max-value][color-
code], for example:  
 
[0][90][0x78C679] 
 

• Using multiple data files  
(StatPlanet Plus only). The column “FILE” is used to link to other data files, when data is spread out 
over multiple files. This is useful to reduce the initial download time, and only download data for a 
particular category when a user selects this category. To load data for a particular category from another 
file, specify the file name in the top row for this category, for example “data_category2.csv”.The file can 
also be inside a ZIP, for example “data_category2.zip”. Each data file has the same structure as the 
original data file. 
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• Options 

o Default year: It is possible to specify the default year to be selected for a particular category. To 
do so, specify the year in the column “OPTIONS”. In StatPlanet Plus, this would need to be 
inserted in the same row as the category name. In other versions of StatPlanet, this would be the 
first row of data in the StatPlanet Data Editor. 

y=[2007] 

o No division: By default, if an indicator has numbers over a million they will be divided by 1000 
000, and ‘million’ will be added as the unit. To prevent this behavior for a particular indicator, 
insert the following in the column “OPTIONS” in the indicator row for the first year in the 
series:  

nodiv 

o Scale for indicator panel bars: The bars in the indicator panel are scaled according to the 
highest value for a country or region in that indicator. This means that each indicator bar has its 
own scale. However, in some cases you may wish the bars of all the indicators to be along the 
same scale. In this case, insert the following in the column "OPTIONS" in the indicator rows you 
wish to be along the same scale: 

samescale 

Please note that this needs to be inserted in the rows for the first year in the series, and that the 
indicators need to be in the same category. 

•••• Data type 

The column “TYPE” will be used to specify the data type in future versions of StatPlanet. This will 
enable additional interface and visualization options. 
 

6.3 Country / region popup text and links 

Country / region specific information can be shown in a popup when the mouse moves over the country / region 
in the map or graph panel. This information needs to be added in the very first row in the empty cell below the 
corresponding country / region name2. (These cells are empty, because country data starts in the next row).  
 
You can insert plain text, or HTML text with formatting, for example:  
 
<font size="15" color="#347C17">My text</font> 
 
Links to documents or web-pages can also be specified in the row below the corresponding country name. The 

                                                 
2 Note: it should be below the country / region name in the sheet ‘Import’ of the StatPlanet Data Editor. Alternatively if you are not 
using the StatPlanet Data Editor, they can also be inserted directly in the file settings.csv in the column next to the country / region 
name. 
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document or web-page will open when the user clicks on a country for which a link has been specified. An 
example of a link would be: 
 
http://www.mywebsite.com/document.pdf 
 
It is also possible to have both text and a download link, by inserting the link as HTML code. For example: 
 
<a href=’http://www.mywebsite.com/document.pdf’>Insert additional information here</a> 
 

6.4 Custom ‘zoom-to’ map regions 

You can add, remove or change the region names in the worksheet ‘Map regions’. For example, in a world map 
a custom region could be Africa. Clicking on Africa from StatPlanet’s region selection drop-down menu would 
zoom into the African continent and display map and graph data only for African countries. 

Map regions have the following elements: 

• Name (col. 1): The names of the map regions you wish to define. If you wish to group regions into a 
sub-menu, insert the name of your sub-menu just like any region name. Then for the subsequent region 
names below, add ‘>’ if you wish to include them in this sub-menu (the principle is the same as with the 
categorization of indicators). In the example below, “My sub-menu” is the name of your sub-menu, and 
the symbol “>” is used to define the two regions to be included in this sub-menu: 

Region 1 
Region 2 
My sub-menu 
> Region 3 (inside sub-menu) 
> Region 4 (inside sub-menu) 
Region 5 (not inside sub-menu) 
etc. 

• Map coordinates (col. 2-4): The X and Y coordinates and ZOOM level for the defined regions. To get 
these coordinates, open your map in StatPlanet and zoom into the map area you wish to add (e.g. zoom 
into Africa and click and drag the map so Africa fills the screen). Once you are satisfied with the map 
position, right-click anywhere in StatPlanet and select 'copy map coordinates'. Go back to the Excel 
sheet ‘Map regions’, and ‘paste’ the coordinates in the corresponding row for the region. 

• Color (col. 5 - optional): The color for each region which will be used to color the bubbles in the scatter 
plot graph. It is also possible to color the bar chart using the region colors. A region colors needs to be 
specified as a “hex color”, for example “0x0000FF” for blue.  

• Link (col. 6 – optional, StatPlanet Plus only): Insert a link or URL, for example to link a map name with 
another copy of StatPlanet with this map embedded. It is also possible to use this feature to link to 
documents for download. 
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• Codes (col. 7 onwards): Columns 7 onwards contain the codes for the countries or map areas in each 
region (these are ISO3 country codes for the world map version of StatPlanet). The codes for each 
country or map area can be found in the top row of the sheet ‘Data’. To add countries or map areas to a 
custom region, add the codes in columns 7 onwards without leaving any empty cells between them. 

6.5 Add cities, countries, regional aggregations, points of interest 

Cities, countries, regional aggregations etc. can be added to StatPlanet and will appear in the graphs and 
country/region list. In StatPlanet Plus, they can also be added as ‘map points’ (for example, a “city point” 
placed in a country map). The procedure is as follows: 

1. Open the StatPlanet Data Editor and in the worksheet "Import" go all the way to the last country or map 
region at the end of row 2. 

2. Insert the name(s) of your map point(s) in this row and press the button Save data. Data can be added in 
this column in the same way as with any other map area. You will need to add some data for this map 
point in order for it to appear in the map. (Note: once you have pressed Save data, the map point name 
should also have been added in the worksheet “Data”. If you cannot see the map point in StatPlanet, 
please check the worksheet “Data” to confirm it has also been added here). 

StatPlanet Plus only: 

3. When you next open StatPlanet, one or more map points (in the form of a circle) will appear in the top 
left corner of the map, representing each of the new map areas added. Right click anywhere inside 
StatPlanet and in the popup select ‘Move text labels or map points’. Click on the map point and then 
click anywhere on the screen to move it to this new location. Similarly, the text label for a map point can 
be dragged and dropped to a new location.  

4. To copy the map point coordinates, right click again and select ‘copy map point coordinates’. 

5. Open the StatPlanet Data Editor and go the sheet ‘Settings’. Scroll down to ‘Special options’ and next to 
M-DOT-COORD paste the coordinates you just copied. In this section you can also set the size of the 
circle representing the map point. Click on Save Settings to save. 

6.6 Data editing without Excel 

You can edit the data files data.csv and settings.csv directly without using the Excel-based Data Editor. These 
two files can be edited using any spreadsheet software.  

The data needs to be saved as a CSV ('comma separated values') file. 
 

6.7 Language and translation 

To change the language, see the Excel sheet 'settings' in the StatPlanet Data Editor. To modify a translation or 
add a new language translation, see the Excel sheet ‘Text-Translations’. StatPlanet is available in the following 
languages. See also below on how to use international character sets such as Russian (see below). 
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• Bahasa Indonesia (courtesy of the Government of Indonesia) 

• Danish (courtesy of Peter Erbs-Maibing, Research Centre for Prevention and Health, Denmark) 

• Dutch 

• English 

• French 

• German 

• Greek 

• Portuguese Brazilian (courtesy of the Instituto Centro de Vida) 

• Russian (courtesy of Andrey Loschilov) 

• Spanish 

StatPlanet Plus also has support for international character sets. To use them, please follow these steps: 

1. Remove the file "settings.csv" in the main directory and also in the directory 'web'. 

2. In the StatPlanet Data Editor, go to the sheet "Settings". Under Startup options - Data format, select: TXT 
(tab-separated values). Then click on “Save settings”. 

3. The international character sets can now be used in the offline version of StatPlanet. For the web version, a 
testing version is currently only provided for the Shapefile map version of StatPlanet Plus, in the directory 
“int_character_sets”. Copy the file ‘content.swf’ in this directory into the directory ‘web’, replacing the existing 
file. 

The following character sets are available: 

• Arabic 

• Armenian 

• Chinese (All character sets) 

• Cyrillic (for Russian, Serbo-Croatian and Tajik, amongst others) 

• Devanagari (for Hindi, Marathi and Nepali, amongst others) 

• Greek 

• Hebrew 

• Japanese (All character sets) 

• Korean (All character sets) 
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• Latin I, Latin Extended A, Latin Extended B, Latin Extended Add'l 

• Thai 
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7. DESIGNING A MAP USING ADOBE FLASH 

To create custom interactive maps using StatPlanet, you need the following: 

• StatPlanet Map Maker 

• Adobe Flash CS4 or higher 

• A map file in vector format, either Adobe Illustrator (.ai), FreeHand (.fh*, .ft*), or Adobe Flash (.swf). 
(See also: Converting images into a suitable vector format) 

For an example of what the final result could look like, see the file 'map_example.fla' (shown below). 

 

StatPlanet Example Map of Kenya (map_example.fla) 
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7.1 Using the map template 

To prepare the map so it can be loaded into StatPlanet, you need to open the map template - 'map.fla' - which is 
in the 'StatPlanet_Custom_Map' folder. This file contains the following four layers: 

• Map layer: This layer will contain the map shapes (e.g. regions or provinces). 

• Borders layer: This layer will contain the map borders. 

(Note: since version 2.3, map text labels are automatically generated and no longer need to be added manually). 

Step 1. Map layer 

Before inserting your map into the map template (map.fla), it may be easiest to edit it first in a new document. 

• Open a new document (File -> New).  

• Import your map. Go to File -> Import to Stage, and select your map file. 

• Once the map is imported, select and remove the details you do not need such as text labels, roads, etc. 
(Click outside the selected area to deselect it, then click on any of the details you wish to remove and 
press delete). 

• Select all (Edit -> Select all).  

• Break apart the shapes of your map by pressing CTRL+B (or using the menu: Modify -> Break Apart). 
You may need to repeat this several times until the shapes cannot be broken apart any further.  

o What to do if a rectangle appears which covers your map: 
In some cases a rectangle may suddenly appear which was previously hidden from view. If this 
is the case, click anywhere outside the selection area to deselect it. Then click on the rectangle 
and press 'delete'. You should now see the map again. (Note: if you did 'Break Apart' one too 
many times, the rectangle and your map merge, and the map disappears. You will need to go 
back and redo this, and remove the rectangle while it is still a seperate shape). 

• Select all (Edit -> Select all).  

• Copy the map (Edit -> Copy). 

• Open the map template (map.fla). 

• Select the first frame in the timeline in the layer 'map' (normally in the top of the screen, see also the 
example screenshot above - the first frame looks like a white rectangle with a circle in it). 

• Paste your map (Edit -> Paste in Place). 

• Double-click on the map borders. This should normally select all the borders in one go. Otherwise, hold 
down the Shift key and double click on the remaining borders. Once you have all your borders selected, 
change the border thickness in the Properties Panel. Click on the drop-down which currently has 'Solid' 
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selected, and change this to 'hairline'. If the borders are different colors, make them one color by 
clicking in the color selection box. Select any color (for example black). 

• Now select the different shapes of your map one by one and convert each of them into a Movie Clip. To 
convert them into a Movie Clip, press F8 (or use the menu: Modify -> Convert to Symbol).  

o What to do if shapes do not separate properly: 
In some cases the shapes of your map may not have separated properly, because the borders are 
not properly joined up. You can either draw existing borders to make them join up, or draw them 
in using the pencil tool. To join them up, you can click on the edge of one of the lines just at the 
point where it does not join up, and drag the line to where it should join. Alternatively, click on 
the Pencil Tool in the Drawing Toolbar (normally on the left). Then draw in the lines where the 
gap exists. If this is done correctly, the shapes should now be separated. 

o What to do if your map consists only of map boundaries, not shapes: 
If your map consists only of map boundaries or borders, you can fill the boundaries with the 
'Paint Bucket Tool'. Select the 'Paint Bucket Tool' in the Drawing Toolbar (normally on the left) 
and click within the map boundaries you wish to fill. It can be filled using any color. 

• Assign an instance name to each of the movie clips. The instance name can be entered in the properties 
panel which is normally below the stage (see also the example screenshot above). 

• The instance name cannot contain spaces. Therefore, you may wish to assign a 'code' rather than the 
actual name. The actual name can be defined later in the StatPlanet Data Editor, where it can include 
spaces. 

• The size / position of the map can be adjusted at a later stage in the Data Editor (in the Excel sheet 
'Settings'). 
 

Step 2. Borders layer 

• Once you have created the map Movie Clips, your borders may have become hidden from view. To 
make them appear again, you need to select all the map Movie Clips you just created one by one, while 
holding the SHIFT key. Once you have selected all of them, select Edit -> Cut. You should see the map 
boundaries reappear.  

• Now select the map borders by double-clicking on any part of them. This should normally select all the 
borders in one go. Otherwise, hold down the SHIFT key and double click on any of the borders which 
are not yet selected. Once you have selected all the borders, press CTRL + G (or use the menu: Modify -
> Group). 

• Once you have grouped all the map borders, you can place all the Movie Clips back again. Select Edit -> 
Paste in Place. While the Movie Clips are still selected, right-click on any of them, and from the popup 
menu select Arrange -> Send to Back. Now your map borders should appear on top of the map. 
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• Click anywhere outside the selection area to deselect it. Then click somewhere on the map borders. This 
requires some precision so that you do not accidentally click on one of the map Movie Clips instead. 
Once you have selected the borders, go to Edit -> Cut. Then select the first frame in the 'borders' layer in 
the timeline panel, and go to Edit -> Paste in Place. 

• While the borders are still selected, turn them into a Movie Clip by pressing F8 (or using the menu: 
Modfiy -> Convert to Symbol). 

• In the Movie Clip properties panel below the stage, give the Borders Movie Clip the instance name: 
borders. 
 

Step 3. Publish your map file  

• Once your map is ready, publish the file (File -> Publish). 

• Go to the directory containing map.fla. You should see a new file, 'map.swf'. Copy and paste this file 
into the directory “Web” (for the online version of StatPlanet), replacing the existing 'map.swf'. 
 

Step 4. Linking the map in StatPlanet Data Editor 

• In StatPlanet_data_editor.xls, first insert the 'real names' of your map regions, and then the 'instance 
names' or codes which you used in the map file (map.fla). 

• In the sheet 'Import', replace the example names (which are Kenya province names) with your own 
names, in the order that you wish. Then press the button 'Save data'. 

• Go to the sheet 'Data' (see the sheet names in the bottom left of Excel). In the top row you should see a 
list of example codes (CEN, COA, EAS, etc.). Remove these codes and replace them with the codes 
(instance names) you have used in your map file. They should be in the same order as the map names in 
the sheet 'Import'. (in the example, the order of map regions in the sheet 'Import' is Central, Coast, 
Eastern...etc., and the corresponding codes in the sheet 'Data' are CEN, COA, EAS, etc.). 

• Go back to the sheet 'Import' and insert the data for your map regions here. You can also use the 'Import 
data' button to import your data from a file automatically. If the import fails, it is most likely because the 
names of map regions in the file you are importing could not be recognized. In that case, you need to 
add them in the sheet 'Import names'. See also the section on “Importing data”. 

• Once the data has been added, press the button 'Save data'. 

• Go back to the directory Offline and open StatPlanet.exe to see your map in action. Or go to the 
directory Web and open the file StatPlanet.html to open it in a web-browser. If you wish to publish your 
interactive map on a website, copy and paste the contents of the folder 'Web' to the web-server. See also 
the file 'StatPlanet_small.html' for an example of how the map can be integrated into an existing web-
page. 
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Step 5. Map positioning: (optional) 

To change the position and size of the map, move the mouse to the bottom-right of the screen to see the map 
zoom controls: 

• Zoom: You can zoom in and out of the map using the 'zoom in' and 'zoom out' buttons, or by dragging 
the zoom slider up or down. If your mouse has a scroll wheel, you can also use this to zoom in and out. 

• Moving the map: click and drag the map with the mouse to move it to a new position. 

Once the map is in the right position, right-click and select 'Copy map coordinates'. In the StatPlanet Data 
Editor, go to the sheet 'Map regions', select the cell below 'X'. Then paste the coordinates here. 
 

Step 6. Text labels: (optional) 

8. To hide/show the text labels for the map, click on ‘Show text labels’ in the StatPlanet Data Editor (sheet 
Import, below the Save button).  

9. Click on “Save data” and open StatPlanet to see the results. It is likely that the position of some or all of 
the text labels will need some adjusting.  

10. To adjust the position of the text labels, right click anywhere in StatPlanet and select ‘Move text labels 
or map points’ in the menu. Click on any of the text labels to drag them to a new position. 

11.  Once you have finished moving the text labels, right click and select ‘Copy text label coordinates’ in 
the menu. 

12. In the StatPlanet Data Editor, go to the sheet ‘Settings’. Select the cell next to ‘Text label coordinates’, 
and paste the coordinates here. (You may also wish to modify other settings in this sheet, such as the 
text font size.) 

13. Click on ‘Save settings’ (or alternatively, ‘Save data’ in the Import data screen). The coordinates have 
now been saved for when you next open StatPlanet.  

14. In the sheet ‘Settings’, you can also change additional settings such as the font size of the text labels. 
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7.2 Converting images into vector format 

Converting a GIS shape file (.SHP) into a vector format recognized by Adobe Flash  

Maps for GIS (Geographic Information Systems) are commonly exchanged as ESRI Shapefiles. Such files can 
be converted into Adobe Illustrator vector files using software such as ArcGIS or MAPublisher. Converting the 
file in ArcGIS can be done as follows: select 'File -> Export Map'. In the 'Save as' drop-down select 'AI' as the 
file format. Then click on 'Save'. Adobe Illustrator (AI) files can be imported directly into Flash.  

You may also wish to open the image first in Adobe Illustrator, export the image as a Flash SWF file, and 
import the SWF into Flash. Importing an SWF file sometimes leads to better results than importing an AI file. 

If you do not have access to such software, you could try a free Shapefile to SVG converter called shp2svg. See 
below for converting an SVG image into a format recognized by Flash. 

Converting a vector image (such as SVG) into a vector format recognized by Adobe Flash  

Use Adobe Illustrator to open the file, and then export the file into the right format. It seems that the best results 
are achieved when using Adobe Illustrator to export the image as an Adobe Flash SWF, then importing the 
SWF into Flash. 

If you do not have Adobe Illustrator, you could try converting the file using the free vector graphics editor 
Inkscape. You may also wish to try this free SVG2SWF conversion tool. 

Converting a Bitmap image into a vector format (e.g. GIF, JPG, PNG, BMP) 

It is impossible to perfectly convert a Bitmap image into a vector one, but with some experimentation it is 
possible to achieve good results. To convert a Bitmap image, first import it into Flash (File -> Import to Stage). 
Then select the image, and select Modify -> Bitmap -> Trace Bitmap. 

You will need to experiment with the following trace settings to get optimal results: 

• Color threshold: Increase this value to decrease the number of colors in the resulting vector image. 
(When comparing two pixels, if the difference in the RGB color values is less than the color threshold 
specified here, they are considered to be the same color). 

• Minimum area:  Increase this value to decrease the number of shapes in the resulting vector image. This 
is the number of surrounding pixels considered when assigning a color to a pixel. 

• Curve fit:  How smoothly the outlines will be drawn. 

• Corner threshold: Select how many corners you wish to keep. 

The following values illustrate what settings to use if you wish to create a vector that most closely resembles the 
original bitmap. However, the settings below are not recommended due to the large number of shapes created. 
These settings may also cause the Flash software to crash. 

• Color Threshold: 10  
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• Minimum Area:  1 pixel  

• Curve Fit:  Pixels  

• Corner Threshold: Many Corners 
 
 

Manually tracing the outlines 

If automatically tracing the image does not lead to the desired results, you can draw the outlines by hand. 
Unless your map if quite large or complex, this is not necessarily a very long process. It can be done as follows: 

1. Convert the map into a Movie Clip (Modify -> Convert to Symbol). 

2. In the properties panel below, click on the 'Color' drop-down and select 'Alpha'. Change the value to 
around '30%' (so you can still see the outlines of the map clearly). 

3. Insert a new layer (Insert -> Timeline -> Layer). 

4. Select the Line tool for the Drawing Toolbar, and draw the outlines in this new layer following the 
outlines of the map in the layer below. Make sure that all the lines are touching. To draw a curve, first 
draw a straight line. Then, click somewhere in the middle of the line, and drag it one way or another. 

5. Select the Paint Bucket tool and click inside the borders to create your map regions. If it does not work, 
the borders you have drawn are probably not touching. Zoom in to see if you can detect the breach. 

6. Remove the bottom layer containing your bitmap image. 

7. Follow the steps above to convert your map for use in StatPlanet. 
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8. REDUCING THE DOWNLOAD SIZE OF YOUR WEB APPLICATION 

StatPlanet is optimized to keep the file size as small as possible. The following is a list of measures which can 
be implemented to reduce the file size of your interactive maps even further: 

1. ZIP the data file(s): this can reduce the file size by as much as 70 percent. StatPlanet will automatically 
detect whether the data is inside a ZIP or not. The name of the ZIP archive needs to be “data.zip”. If you 
have multiple data files (StatPlanet Plus only), these can also be zipped. 

2. Decimal places: file sizes can often be reduced by around 50 percent if you round numbers to two or 
three decimal places. A macro is included in the StatPlanet Data Editor for rounding all the numbers in 
the Excel sheet ‘Import’ to two decimal places. The macro is called “RoundToDecimalPlaces” and can 
be adjusted as required. 

3. CSV file format:  the CSV file format was chosen because it keeps the size of the data file to an absolute 
minimum, because data values are separated only by commas. In comparison, XML files are often 
several times bigger when containing the equivalent amount of data. 

4. No duplication: indicator names and descriptions do not need to be duplicated in the data file. If you are 
using the StatPlanet Data Editor, any duplicate indicator names will automatically be replaced with the 
‘-‘ symbol. Indicator names only need to be indicated for the very first year of a data series. For 
indicator descriptions, duplication can also be avoided – see the section “Indicator Description” for more 
information. 

5. Reduce map size (shapefile version only): the maps themselves are often much bigger than StatPlanet 
and the data files combined. GIS software can be used to reduce the level of map detail. There is also a 
free utility called MapShaper – www.mapshaper.org . However, when using MapShaper the exported 
map still needs to be imported and then exported again using GIS software to make it compatible with 
StatPlanet. 

 

 

 


