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1. WHAT IS STATPLANET

StatPlanet is a powerful interactive data visuélimaand mapping tool. It is used by many differkimds of
organizations including UN agencies, Fortune 506manies, government departments, NGOs, schools
universities to communicate and explore data. &a#® is not only for adults — it is also used bydren (ages
9 and above) to learn about the world through attive maps.

One of the greatest strengths of StatPlanet istteafbles also non-technical users to explotissts through
its user-friendly interface. Moreover, the softwargomates the normally complex processes of ctingeiaw
data into interactive maps and visualizations. BEmables even non-technical users to create itiezanaps
and visualizations with relative ease. You can ihgour own data into StatPlanet, as well as youn onaps
(both Flash maps and ESRI shapefile maps) — ocgowse the included world or USA maps.

StatPlanet comes in different versions to catetifferent needs. All versions of StatPlanet are fegcept for
StatPlanet Plus, which has more advanced featuotsas support for large datasets. All versionStatPlanet
can be used both as a stand-alone applicationffimeouse, and as a web-based application which loa
published online. The offline version of StatPlaRets is free for non-commercial purposes.

The aim of StatPlanet is to promote evidence-badedsion making by improving and facilitating the

communication and interpretation of informationat®tanet does this by providing (i) attractive iatgive

visualizations which facilitate the interpretatiohinformation, (ii) a user friendly interface thet accessible
also to non-technical users, (iii) automated daisualization (including the processes of mergingl a
synchronizing data from different sources), and &n easy to disseminate software system whicheoable
anyone to explore and create data visualizatiomegardless of technical skills, availability of émet
connectivity, and computer hardware or software.

StatPlanet was conceptualized and is being develbpd-rank van Cappelle since 2005. From 2008 020

and

n

the development of a tailored version of StatPlawmes undertaken as part of the SACMEQ research

programme at the UNESCO International InstituteHducational Planning (IIEP).
For more information:

«  SACMEQ websitehttp://www.sacmeq.org/statplanet




2. STATPLANET SYSTEM REQUIREMENTS

StatPlanet was designed to be usable in as maogspbkes possible regardless of the available comgpatel

infrastructure. It can be used online, throughraranet as well as offline — making it usable iagals where
there is no Internet connectivity. It is easy teséiminate due to its very small size — small endaadh on any

USB flash drive (USB stick) or to be sent as anagtattachment. The software does not require liasitan, so

even those without administrator rights on theird@@ run both the offline and online versions.

StatPlanet runs in the Adobe Flash Player, whichtha following minimum system requirement&s can be
seen in the table the system requirements aredo@any computer purchased within the past 7 yswasld be
able to run StatPlanet.

Windows® Macintosh Linux®

Intel® Pentium® Il 450MHz, AMD Athlon™ PowerPC® G3 500MHz or  Modern processor
600MHz or faster processor (or equivalent) faster processor (800MHz or faster)

Intel Core™ Duo 1.33GHz
or faster processor

128MB of RAM 128MB of RAM 512MB of RAM, 128MB
of graphics memory

128MB of VRAM*

*Recommended for GPU hardware acceleration—depémelaiures. Flash Player will use software mode for
systems that do not meet the system requirements.

! http://www.adobe.com/products/flashplayer/systersteq




3. STATPLANET FEATURES AND OPTIONS
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3.1 Thematic map

Choropleth Map

This is the main thematic map type in StatPlanké map legend shows which map colors are
ﬂ associated with each data range (for example, higdlaes may be shaded in increasingly
“« " darker colors). Both the map colors and the datgeaan be customized (ddep legend
below). In version 2.1, the possibility of creatiepgalitative or descriptive maps was
introduced. These types of maps convey non-nunienifcamation, such as which languages
are spoken in different regions.

Proportional Symbol Map
ﬁ A proportional symbol map scales symbols (usuatgles) according to the indicator being
mapped. Each symbol can represent a country or otap region. In StatPlanet the symbol




map is overlaid on top of the choropleth map (de®v@). This means that two data sets can be
shown on the same map — one for the choroplethandpne for the symbol map.

To show the symbol map, click the symbol icon (sham the left) in the bottom-left corner of
the screen. If you have bookmarked an indicater sgmbol map represents the data for the
bookmarked indicator, whereas the choropleth mppesents the data for the selected
indicator. (If the bookmarked indicator is currgrgelected, both the symbol map and the
choropleth map represent the bookmarked indicator).

Select country on the world map

* Mouse over a country Moving the mouse over a country on the world rbgpgs up a
popup containing information about that particauntry for the selected indicator (as
well as the bookmarked indicator, if there is oe)addition, the country data for all
indicators in the current category is shown inititicators panel.

» Click on a country: You can select a country by clicking on it in thap. This will
highlight the country in the graph, and can alsai$ed to define a custom region. See
also thecountry selection panel.

Map legend

Map colors: Clicking on any of the colors in the legend wiliry up a color selection pandh

this panel you can change both the colors (eiteguéntial or Diverging color schemes), as
well as the number of color classes (between 3andhe color schemes are from the Color
Brewer websitelttp://colorbrewer2.org/ which is an excellent resource for more infolorat

on selecting map colors.

Data range: To adjust the data range of the map legend, clicthe top or bottom value. Use
the popup to increment or decrement the valuentara whole new value. The intermediate
values will be adjusted automatically.

Custom maps (national / regional / state maps etc.)

You can use StatPlanet Map Maker to insert your ovaps, using the included map template
(map.fla). This requires the Adobe Flash softwé8ee:5. Importing a map into StatPlanet)

Save/export(category version of StatPlanet only)
You can find the save/export button in the botteft-torner of the screen. This button enables
you to save the current map or graph as an imaggwnload the data as a CSV file.

To change the image type, size or quality, uset®ns panelThis feature is only available
the online version on the StatPlanet website. Hawnevis possible to save an image of a map
produced with your own data if you download StatBtaMap Maker. You need to open
StatPlanet in the directory 'Offline’, click th@icshown on the left, and take a ‘Print Screen’
(Prt Scr button on the keyboard). This saves timeris of the screen, so that it can be pasted




in an image editor or document.

Please include a reference to StatPlanet if yopaldishing the image.

Map navigation controls:

The map zoom controls are normally hidden from viBleve the mouse towards the bottom-
right of the screen to make them appear.

3.2
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« Zoom: You can zoom in and out of the map using the 'zovm@and 'zoom out' buttons,
or by dragging the zoom slider up or down. If yowsuse has a scroll wheel, you can
also use this to zoom in and out.

« Moving the map: click and drag the map with the mouse to move & hew position.

+ Restore map position the button shown on the left restores the mapeatiginal
coordinates for the selected region.

Indicators panel

Select category

Use the drop-down menu in the top of the indicapansel to select a new category (online
version only).

Select regions

Use the drop-down menu in the top of the indicapansel to select and zoom into a different
region, such as 'Africa’ or 'Europe’. It is alsegible to select countries to define a custom
region (see&Country selection panel).

Indicator bars

The bars are scaled in proportion to the maximuluwevaf that particular indicator for all
countries in the selected region. For exampldgfitalue for country X is 20 and the
maximum value for all countries is 100, the bail W scaled at 20%.

Bookmark indicator

Click the 'star' button in the indicators panebtmkmark the selected indicator. The
bookmarked indicator will stay even when you switelanother category. This allows you
to (i) create scatter plot graphs, (i) comparelibekmarked indicator with indicators from
other categories, and (iii) compare two indicatbrsugh the choropleth map (representing
the selected indicator) and the proportional synmbap (representing the bookmarked
indicator).

Indicator definitions

If a definition exists for an indicator, the defion will appear in a popup when moving the
mouse over the indicator. The definition only shdarsthe indicator which is selected or
bookmarked.




3.3 Graph panel

- K [«

Bar chart

Click the 'graph’ button in the bottom-left coriéthe screen to open or close the Graph panel.
You will find the same graph button in the grapinglaUse this button to switch between
horizontal and vertical bar charts.

Use the "sort" button to sort the graph from lowtegtighest, highest to lowest, highest to
lowest starting in the middle, or alphabetically.

Time series

In the top left of the Graph panel (see "Bar chaktdve) you will find the time series button.
When you click on this button, a list of countraggpears which you can add to the time series
graph. Click on a country to add it to the graph, elek on it again if you wish to to remove
(See als&Country selection panelbelow).

Use the "sort" button to sort the time series Ilsbel

Scatter Plot

In the top left of the Graph panel (see "Bar chaktdve) you will find the scatter plot button.
Clicking on the button will automatically use thelexcted indicator as the x-axis variable. You
need to select a second indicator as the y-axiablar

The x-axis and y-axis variables can be selecteédarGraph panel (see below), or in the
Indicators panel (seg@ookmark indicator above).

Press the ‘play’ button to see an animation of gearover time, with each bubble moving to
the corresponding x and y positions (depending bether data is available for each time
interval). If ‘Show trails’ is selected (next toetiplay button), each bubble will leave a trail to
mark previous positions over time.

Select x-axis / y-axis indicator
Click on the x-axis or y-axis label, then seleciraticator from the drop-down menu

Use the drop-down menu in the top of the graph Iganghange the scale of the 'bubbles’
according to a selected indicator.

Use the 'options' icon in the graph panel to shoiide the trendline. Movihe mouse over tr
trendline to see the slope and trendline equation.

Adjust graph size

To change the graph size, move the mouse to tlee sidcorners of the graph panel until you
see the cursor change to look like the one showth@teft. Click and hold down the left mot
button, then drag the panel to the size you wRalease the mouse button once you have the
right size.




Adjust graph scale
The graph scale can be adjusted by clicking onidp®r bottom graph values. The value can
then be edited in the popup panel.

3.4 Options panel

L 2
Click the 'options' button in the bottom-left cormé the screen to open the options panel.

Map:
* Map colors: map background, map borders, map t@gt,cnap text outline color, etc.);
* Map text size;
* Map symbol size (proportional symbol map symbols);

* Map legend - estimate best value distribution: sidilne values so that there is a more
equal distribution of countries for each color slaghis will usually result in a map with
a better distribution of colors. If this is switcheff, the value range for each color class
will be set at equal intervals based on the higaedtlowest value in the data range.

e Map legend - show maximum & minimum values
* Map legend colors.
Graph/Chart:
» Graph colors: background, bar & scatter pointsttscaoint borders;
* Graph text size;
« Transparency level of graph area (bars / bubbles);
» Size of bubbles (scatter plot graph);
» Bullet graph.

General options:

« Animation duration;

« Decimal places shown;

« Adjust the map/graph scale StatPlanet automatically adjusts the map and gseple
to suitthe data set. However, in some cases you may wikedp it fixed, for example
you made some changes to it yourself. You canosgirévent) the automatic updating
the map/graph scale on (i) changing indicator cfidnging region, (iii) changing year.
The default setting is for StatPlanet to adjuststee when changing indicator or regi




but not year.

If you have chosen to not have the map scale uggdtte map legend has a shortcut
which you can use to 'refresh' the map legend atatime for the current indicator,
year and region:

C

Save/export map: (online version only)

« Set themage type PNG or JPEG
« Change thémage sizeas % of original
« Change th@mage quality (for JPEG images only)

3.5 Data table panel

Click the 'table' button in the bottom-left cormérthe screen to get a data table of the selected
indicator. If an indicator has been bookmarked,d&ta for both the bookmarked and selected
indicator will be displayed. The table also sholes thean, standard deviation and range.

Save / Export table(StatPlanet Plus only)
Save the table as a .CSV file, which can be opégeadost spreadsheets (such as Excel). You
can find the save table button in the top-rightheorof the table panel.

Copy table
BN The offline version of StatPlanet does not allow yo save the data as a file. Instead, you can
5 copy the entire table into Excel using the 'copytdn, and then 'paste’ it in Excel. If you do not
have Excel, you can also do the following: (i) paste data into a basic text editor such as
Notepad, (ii) save the document as 'data.htm) dfien the file using your Web Browser.

3.6 Selecting countries

Countries can selected in various ways. An efficieaty of finding and selecting a country is througé
country selection panel, as explained below. Howeveountry can also be selected by clicking on ihe
world map, in the data table panel, or in the lbaricor scatter plot graph. In each case the cpwviti be
highlighted in all of these StatPlanet components.

Click the 'select' button in the bottom-left coreéthe screen to get a list of countries. Then

click to select the countries you wish to show o thap or in the graph pan&b narrow dow
3 the list of countries, select a region from thepddown menu in the top-right corner of the

screen. You can also press the first letter ofumtty name to quickly jump to a country in the
list.




Select button

Press the Select button to confirm your selectary. variables which are not selected will be
removed from view.

Note: for the time series graph, there is no need tespifeis button as the countries will appear
in the graph panel as soon as you click on them.

[«

Deselect All button
Press the Deselect All button to clear your sebecti

Refresh button
The Refresh button . It only appears after you leie&ed the Select button.

Remove countries
To remove countries, select the countries you wasiemove and press this button.

E O

3.7 Time slider

2000 2007
1 1 I 1 1 | B | 1 1 1 1 1 1 ] ’

Use the slider or click on the arrow buttons tondeathe year. Click on the play button to show gesrover
time as an animation, starting from the beginnifige animation speed can be set in the Options panel

1991

3.8 View menu (show/hide items)

Move the mouse over the 'View' button in the botlefhof the screeto see various optior
for showing or hiding map & graph elements, anceo®tatPlanet components.

« Show or hide country/region names on the map glgfeountry names can be
shown in full, in abbreviated form or #03 codek
« Show or hide country statistics on the map or gi@phntry statistics can only be
shown on the horizontal bar chart);
« Show or hide the map popup and its components ehmat, indicator and statistic;
« Show or hide various panels.




3.9 Options panel (resizing/scaling)

Shrink / enlarge panels:Use the buttons shown on the left to shrink or rgiddhe

a StatPlanet panels. This may be useful for spaceageanent when you have several
panels open at the same time, or to focus in dliceareas.

Minimize / maximize panels: Use these buttons to minimize or maximize the ganel
a E Theindicators panelhas a special minimized state in which indicataus still be
selected.

I Adjust graph panel size
Drag and drop the graph panel borders to adjustitee

E E Fullscreen: Click on this button in the bottom-left of the seneto either switch to
fullscreen mode, or go back to normal panel mode.

Additional notes:

« When switching categories, StatPlanet will rememid@ch year was selected and check if data exists

for this year in the new category. If there is abedfor this year, it will select the year closesthe
previously selected year for which data is avadablthe new category.

« When switching maps (e.g. world map to country nogrom regional map to district map), StatPlane

will check if the same category and indicator exighe new map. If it cannot be found, the first
category/indicator in the data set will be selected

10
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4. IMPORTING ESRI SHAPEFILE MAPS

These are instructions for SatPlanet Plus.
For SatPlanet Lite, see http://mwww.sacmeg.or g/statplanet/SatPlanet-lite.html.

Instructions for loading your own ESRI shapefiles mto StatPlanet:
1. Go to the folder containing the shapefile versibSt@atPlanet, go to the folder ‘map’.

2. Remove the included example shapefiles (map ofnesia), and copy your own shapefiles here.
*both offline and web versions have a map foldieypu are using both, copy them to both map foldees
“my_statplanetimap” and “my_statplanet\web\map”).

3. Rename your files (e.g. xyz.shp and xyz.dbf) togmehp” and “map.dbf”

4. Open the StatPlanet_data_editor file. Click onlthton 'Setup shapefile' (in the top-left).
5. Select the “map.dbf” file in the 'map’ folder, aiotlow the instructions.

6. Run StatPlanet to see the results with the incledeaple data.

You can now start importing or inserting data fouymap, but first you may wish to modify the magsigion
and add text labels.

Map positioning:

To change the position and size of the map, moserthuse to the bottom-right of the screen to seentp
zoom controls:

« Zoom: You can zoom in and out of the map using therzo® and 'zoom out' buttons, or by dragging
the zoom slider up or down. If your mouse has alkatheel, you can also use this to zoom in and out
« Moving the map: click and drag the map with the mouse to move & hew position.

Once the map is in the right position, right-clenkd select '‘Copy map coordinates'. In the StatPRaia
Editor, go to the sheet 'Map regions’, select glebelow 'X'. Then paste the coordinates here.

Text labels:

1.  To show the text labels for the map, click on ‘Shext labels’ in the StatPlanet Data Editor (sheet
Import, below the Save button).

2. Click on “Save data” and open StatPlanet to seeahdts. It is likely that the position of someadirof
the text labels will need some adjusting.

3.  To adjust the position of the text labels, rightklanywhere in StatPlanet and select ‘Move telelsl
in the menu. Click on any of the text labels togditeem to a new position.

4, Once you have finished moving the text labeld)tridick and select ‘Copy text label coordinates’ i

the menu.
11




5. In StatPlanet, go to the sheet ‘Settings’. Seleetcell next to ‘Text label coordinates’, and pdkte
coordinates here. (You may also wish to modify p#wgdtings in this sheet, such as the text forat. siz

6.  Click on ‘Save settings’ (or alternatively, ‘Savatd in the Import data screen). The coordinate® ha
now been saved for when you next open StatPlanet.

7. Inthe sheet ‘Settings’, you can also change aufditisettings such as the font size of the texdltab
Finding a map:

The following are useful websites for finding frelgapefiles (regional / administrative boundariepsha
Note that you need to download the boundary fikethe ".SHP" format.

* Map Library -http://www.maplibrary.org/ - Public domain maps for most countries in thelevo

* UN SALB - http://www.unsalb.org/ - Second Administrative Level Boundaries datgpsefect. These
maps are free but copyright rests with the UN. fitag@s are validated by the National Mapping
Agencies (NMA) of each UN Member State.

» US Census Bureathttp://www.census.gov/geo/www/cob/bdy files.html - USA County and District
Cartographic Boundary Files.

Instructions for loading shapefiles without using Excel:
1. Copy your map shapefiles as explained above.
2. Copy and paste the country IDs from the magfitibfo replace the existing ones in the file dega.

3. Copy and paste the country names from the mafilellbo replace the existing ones in the bottointhe file
settings.csv.

4. Copy the ID column header name, and paste tttoéRBF-ID' in the file settings.csv.

Note: The ID column may not contain spaces or syslamd should have unique values only.

GIS Shapefile Reader - Source Code

The source code for reading the shapefiles is deduin the directory SHPreader. It can be compiettie file
SHPreader.swf, which is read by StatPlanet.

The code was written by Edwin van Rijkom underlt@PL license, with some additions by Andy Woodruff,
and some slight modifications for use in StatPlanet

If you wish to change the names of the map filesdeead, you can change this in SHPreader.asp@alish it
as SHPreader.swf through the file SHPreader.fla.

For more information, seéttp://shp.riaforge.org/

12
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5. ADDING OR IMPORTING DATA

5.1 Basic steps for adding data - country-level data example

Note: to add your own data you need to downloatP&taet Map Maker, StatPlanet Plus or StatPlartet Li

http://www.sacmeg.org/statplanet

1. Download DownloadStatPlanet Map Maker arcktract the filedo your computer.
v
2. Open In the folder '"World_Map', opefitatPlanet_data editdvlake surenacros
_— are enabledPress thé&lear databutton to remove the example data.
3. E} Import Press thémport databutton and select a file containing data you wish t
import. You can alsedd data manuallysing any spreadsheet software.
4, i.__,i Save Press the 'Save data’ button. This saves thdaltiea filedata.csv
5. ) View Click on StatPlanet.ex @ to view the results.
6. Publish Copy the contents of the folder "Wad'your website to publish it online.
-

To publishstatPlanet Map Maker online, all you need to do is to upload the contentdheffolderWeb to the
website (web-server). This folder contains thediwihg files:

» StatPlanet.html (the webpage which displays yatigractive map)

» StatPlanet_small.html (alternative with smaller reagbedded inside a webpage)
» StatPlanet.swf (file which shows loading progyess

» content.swf (the actual software)

» settings.csv (settings in comma-separated véduesat)

e data.csv (datain comma-separated values format)

» swfobject.js (required to run ‘Flash’ content)

Contents of StatPlanet_Map_Maker.zip
* User Guide (User_Guide_StatPlanet.pdf)
» StatPlanet Map Maker Software License (License_$qydf)

* World_Map
- Create interactive maps using the included Wistég.

14




« USA Map
- Create interactive maps using the included USA Ma

* Custom_Map
- Design or import a map using the map templatep(fizg.
(requires Adobe Flash CS3 or higher)
- Includes an example map (map_example.fla), aipcevmap of Kenya.

Enable macros in Excel:

When you open StatPlanet Data_Editor.xls you vatihmally get a message asking you whether you wjsh
to enable macros. The message depends on thernvefdtxcel.

* Excel 2007 or newerin the top of the screen, next to 'Security Waghialick the button
'Options’. Select 'Enable this content’ and click@K'.

» Older versions of Excel:Select 'Enable macros' in the popup window.

If you do not receive this message, the macro ggdavel in Excel is set to high. Follow the insttions
below to change the security level to a lower sgtti

» Excel 2007 or newerClick the Microsoft Office Button (top-left) andick Excel Options. In the
Popular category, check 'Show Developer tab irRibddon’ (if it is not already checked). Click on
'OK’, then select the Developer tab. Click on 'Mesecurity' (on the left). Select 'Disable all
macros with notification'.

» Older versions of Excel:ln the Tools menu, go to -> Macro -> Security. Gi@athe security level
to Medium.

5.2 Importing data

Using the included StatPlanet Data Editor, it isgble to import data automatically. The Data BdgdExcel-
based, so data can be imported from many diffdienformats (including CSV, TXT, XLS, XLSX, DBF ah
HTML).

The Data Editor automatically recognizes the stmecof the data in the file being imported. It alsoognizes
the vast majority of the many possible variatiohsauntry names (in the world map version of Statiet).
The import should therefore succeed in most caggeut having to make any changes to the datalfilease
of problems, see “troubleshooting” below.

The Data Editor uses the names in the Excel shepbft names’ and looks for corresponding names and
statistics in the data file (in the world map versithis sheet contains country names, but it tsma@ontain for
example region names or district names, dependirtge@map used). The Data Editor automatically
restructures the data in the format that is acdepyeStatPlanet.

15




A criterion for the import to be successful is thay country namenly appears once in the data file being
imported. Also note that StatPlanet sees a "dotha@slecimal separator.

Importing HTML or PDF files

« HTML: To import data from a web-page, simply salve web-page and import it like any other file. If
the import fails, it could be that the import/mapiatry names and statistics are too far down tige pa
In this case, open the file in Excel, and remowertiws up to the point that the data starts. Thegoit
the file again. Alternatively, copy and paste thiele¢s in the web-page into a new Excel document.

» PDF: Tables in PDF files can usually be copied pested into an Excel file. Select (highlight) thble
with the mouse, right-click and select “Copy as[€abr “Save as Table” from the menu. See also thi
helpful guide from McGill University:
http://www.library.mcgill.ca/edrs/services/publicats/howto/pdftoxis/pdftoexcel.html

as well as this free tool to convert a PDF to andEfile:
http://www.pdftoexcelonline.com

Names not recognized

Names of map regions in the data file which arerecbgnized are displayed once the import is cotapkeor
example, if in your data file the country ‘Afghatar’ is indicated with the abbreviation ‘Afg’, trabbreviation
will not be recognized by the data editor. To fve fproblem, go to the Excel sheet 'Import names'aala ‘Afg’
in an empty cell below the corresponding countAfghanistan’. You can use the same approach fogrot
headers in your data set so that the import maamacorrectly identify them. Then, run the importanmaagain
to import the data correctly.

Note that the import macro removes spaces in thetskmport names” and converts special chara¢eegs
"é") into regular characters (e.g. "e") during tim@ort. This allows for a wider range of countrynmaspellings
to be detected. Whether the names in your filempper or lowercase does not matter. The world neapion
recognizes English and French country name spslimgl a number of variations of these spellingsomatic
data importing has been successfully tested withyndifferent sources of data with different dataistures
and country name variations, including the CIA Baok, Ethnologue, IMF, ITU, Nation Master, OECD, §B
UIS, UNAIDS, UNDP, UNESCO, UNICEF, UNSTATS, WHO atite World Bank.

The Data Editor is registered as an open sourgegiron SourceForge and any contributions or imgnosnts
you make to the software are very welcomep:/sourceforge.net/projects/statplaneteditr/).

5.3 Troubleshooting

If you have saved your data but it cannot be read by StatPlanet, most likely there is a problem with the data structure.
Please see point 4 below to see how to structure data by year (or other time point). Data should start with the more recent
time point. Also make sure that the indicators listed for each year are exactly the same, and are listed in the same order.

If the import fails, check your data file for the following issues:
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1. Spelling of names: If the spelling of any of the country/map/region names cannot be identified, the
corresponding data will not be imported. See “Names not recognized” above for more information on how to
resolve this problem.

2. Names appear more than once: If the same country/map/region names appear more than once in your data file,
the import macro will only import the data associated with the first one.

This structure will not be imported correctly:

Count Dimension High Medium Low

Afghanistan A 6 3 2
B 7 5 2
Albania A 9 6 3
B 12 5 2
Algeria A 11 5 1
B 21 11 9
Andorra A 15 14 12
B 14 11 10

This structure needs to be re-arranged with one country/map/region name per row, as shown below (alternatively,
it may be easier in some cases to split the data into several files and import them separately).

This structure will import correctly:

Country A - High \A - Medium A-Low B-High B-Medium B -Low \

Afghanistan 6 3 2 7 5 2
Albania 9 6 3 12 5 2
Algeria 11 5 1 21 11 9
Andorra 15 14 12 14 11 10

3. No year indicated in the data file, or cannot be detected:
All indicators are arranged according to year. You need to add the year to your data set as the header of a row or
column (depending on how your data is structured). Alternatively, you can import the data and add the year
afterwards. The data needs to be structured as follows (see for example the structure of the sample data in
StatPlanet_data_editor.xIs):

« Group (sort) your indicators according to year. Insert a new row above each group of indicators. In this

new row add the year in the YEAR column. Leave the neighbouring cell in the INDICATOR column blank;
¢ Note that the YEAR column should be blank in the cells next to the indicators:

YEAR INDICATOR

2001
indicatorl
indicator2
2000
indicatorl
indicator2
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4. Decimal point: StatPlanet reads a "dot" as decimal separator (for example 0.75). Avoid using commas, spaces or
other symbols in numbers to ensure that they are read properly by StatPlanet.
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6. CUSTOMIZING STATPLANET

6.1 General settings and customizations

General settings for customizing StatPlanet cafobied in the Excel sheet ‘Settings’. After makinya
changes to the settings, press the bulave SettingsYou can try out most of the different optiondi in
StatPlanet through the general options panel aadép legend options panel. See below for custogizi
StatPlanet at an indicator or category level (f@ameple, specify different map colors for differ@mdicators).

6.2 Customizations and metadata at category & indicator level

In StatPlanet_Data_Editor.xlIs, there are sevedainaos which can be used to define optional pararseide
different columns and their usage is explainedwelo

IMPORTANT : CUSTOMIZATIONS, SUCH AS AN INDICATOR DESCRIPTIONSHOULD ONLY BE

SPECIFIED FOR THOSE INDICATORS IN THE FIRSOR HIGHEST) YEAR. THEY DO NOT NEED
TO BE REPEATED FOR LL YEARS IN THE SERIEC.

Data Source

The source of your data can be added in the samasdhe year in the column “SOURCE?". It only
needs to be added for the first (highest) yeahénseries. In StatPlanet Plus, it can be spedifiedach
category or sub-category of data.

You can choose to use HTML code if you want to adidk to the source website, for example:
<a href="http://www.mysource.com’>My Source</a>.

Make sure you to use only single quotes ‘-’ rathain double quotes (“-”), as double quotes are tsed
indicate the presence of commas (the data.csisfdecomma separated values file).

Indicator Description
Add a description for each indicator in this colymich will appear as a popup in StatPlanet when
moving the mouse over the indicator.

As noted above, the description only needs to beddor the list of indicators below the first yéar
the series. If you have two or more indicators wiith same description, you only need to enter the
description once. For the other indicators, instefaa description enter the Excel row number (m th
sheet ‘Import’) where the description you wanteeuse is located.

Indicator Unit
The unit for the indicator, for example ‘%’.
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Customize Map
In this column you can customize the map legen@éwh indicator. It is possible to customize thg ma
legend values (either text or numbers), colorsyelsas the number of color categories.

The map legend can be customized in StatPlandft &sel then copied and pasted into the datalfile.
StatPlanet, select the indicator for which you wisleustomize the map legend. Then click on any of
the colors or values inside the map legend panttlarbottom-left corner to customize the map. Once
you are satisfied with the map legend you havegustomized, right-click anywhere inside StatPlanet
and select ‘Copy map legend’ from the menu. OperStfatPlanet_Data_Editor file. Select the cell
below the column header ‘MAP’, in the correspondimgjcator row (for which you customized the map
legend). Select ‘paste’ to insert the custom mgpnd. If there is data for multiple years, thisyonl
needs to be pasted in the row for the first yednénseries. Click on ‘Save data’ to see the resh#é
next time you open StatPlanet.

More details on customizing the map legend, ineigdiow to create a qualitative map, are provided
below. If you wish to create a qualitative map ledi¢based on categories such as ‘high’, ‘medium’,
‘low"), rather than a quantitative legend (basechameric value ranges), you need to follow the
approach described in (iv) below.

(i) Map legend with custom values

= Use the following format to specify the values tloe map legend, as well as the number
of color classes:
O=[value0] 1=[valuel] 2=[value2] 3=[value3] 4=[val
etc.

= Example 1la: A legend with 4 color classes:
0=[55] 1=[40] 2=[20]

= Example 1b: A legend with 5 color classes:
0=[70] 1=[65] 2=[60] 3=[55]

Map legend for Example 1b:

With max / min values With max / min values
hidden shown

>70 70 - max value

65-70 65-70

60-65 60-65

55-60 55-60

<55 min value — 55
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(i) Map legend with custom colors

(iif) Map legend with custom colors and values

(iv) Qualitative (descriptive) map legend

Use the following format to specify the colors the map legend, as well as the number
of color classes:

0=[color0] 1=[colorl] 2=[color2] 3=[color3] 4=[cold]
etc.

Example 2: A legend with 4 color classes:
0=[0x238B45] 1=[0x66C2A4] 2=[0xB2E2E?2] 3=[0XxEDF8FB]

Use the following format to specify the colors the map legend, as well as the number

of color classes:
O=[color0][value0] 1=[colorl][valuel] 2=[color2][\ae2] 3=[color3][value3] 4=[color4]

Note that this format is slightly different frometiprevious ones, because 5 colors are
specified (colors 0 to 4) but only 4 values (valQds 3). As illustrated in example 1b

above, a legend with 5 color classes requires 4mglues to be specified (a legend with
4 color class requires only 3 values, and so on).

Example 3: A legend with 4 color classes and custalues:
0=[0x2171B5][3] 1=[0x6BAED®6][2] 2=[0xBDD7E7][1] 3€]xEFF3FF]

Use the following format to specify the map legentbrs, the corresponding labels, as
well as the number of color classes. Countriesaasggned a value which corresponds to
one of the numbers below. For example, if the aguAtfghanistan’ is given a value of
‘0’, it will be associated with ‘colorQ’ and ‘lab@l

O=[color0][label0] 1=[colorl][labell] 2=[color2][lael2] 3=[color3][label3]
4=[color4][label4]
etc.

Example 4: A legend with 8 color classes:

0=[0x377EB8][Arabic] 1=[0xE41A1C][Bengali] 2=[0x4DA4A][English]
3=[0x984EA3][Hindi] 4=[0xFF7FO00][Mandarin] 5=[0xFH33][Portuguese]
6=[0xA65628][Russian] 7=[0xF781BF][Spanish]

Map legend for Example 4:

Color Label
Arabic
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Bengal

Englist
Hindi
OxFF7FO( Mandarir
OXFFFF3: Portugues
Russial
OxF781BF Spanisl

Customize Graph

If you wish to use your own maximum and minimumues for the graph, you can set them in the
“GRAPH?” column. Specify the minimum / maximum vadui@ parentheses in the formftin-
value][max-value]

For examplefor a minimum value of 0 and a maximum value of &fter the following:
[0][80]
You can also specify the color of the graph infdrenat[color-code], for example:

[0x78C679]

To specify minimum / maximum values as well as calse the formdimin-value][max-value][color-
code],for example:

[0][90][0x78C679]

Link To Other Data Files

(StatPlanet Plus only). The column “FILE” is useditk to other data files, when data is spread out
over multiple files This is useful to reduce théial download time, and only download data for a
particular category when a user selects this cagedo load data for a particular category fromtaeo
file, specify the file name in the top row for tltgtegory, for example “data_category2.csv”. The ¢éhn
also be inside a ZIP, for example “data_categoig2.Each data file has the same structure as the
original data file.

Options
o Default year: It is possible to specify the default year to bkested for a particular category. To
do so, specify the year in the column “OPTIONS”StatPlanet Plus, this would need to be
inserted in the same row as the category namehgr gersions of StatPlanet, this would be the

first row of data in the StatPlanet Data Editor.

y=[2007]

22




o No division: By default, if an indicator has numbers over aionllthey will be divided by 1000
000, and ‘million” will be added as the unit. Teepent this behavior for a particular indicator,
insert the following in the column “OPTIONS” in thedicator row for the first year in the
series:

nodiv

o0 Scale for indicator panel bars:The bars in the indicator panel are scaled accgridirthe
highest value for a country or region in that irdar. This means that each indicator bar has it
own scale. However, in some cases you may wisbdheof all the indicators to be along the
same scale. In this case, insert the followindnexdolumn "OPTIONS" in the indicator rows you
wish to be along the same scale:

samescale

Please note that this needs to be inserted irothe for the first year in the series, and that the
indicators need to be in the same category.

« Data type
The column “TYPE” will be used to specify the datpe in future versions of StatPlanet. This will
enable additional interface and visualization apgio

6.3 Country / region specific information and/or links

Country / region specific informatioran be shown in a popup when the mouse movedlwweountry / region
in the map or graph panel. This information needset added in the very first row in the empty bellow the
corresponding country name. (These cells are erbptiguse country data starts in the next row).

You can insert plain text, or HTML text with forntiaig, for example:

<font size="15" color="#347C17">My text</font>

Links to documents or web-pages can also be spddifithe row below the corresponding country nahhe.
document or web-page will open when the user clicka country for which a link has been specifisal.
example of a link would be:

http://www.mywebsite.com/document.pdf

It is also possible to have both text and a dowalow, by inserting the link as HTML code. For exgale:
<a href="http://www.mywebsite.com/document.pdf >émsadditional information here</a>
Custom maps (e.g. province / state / region maps)To add data for new map areas or regions,

first add the map area/region as follows:
23
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6.4 Custom ‘zoom-to’ map regions

You can add, remove or change the region namégiworksheet ‘Map regions’. For example, in a waonlap
a custom region could be Africa. Clicking on Afritam StatPlanet’s region selection drop-down mewnuld
zoom into the African continent and display map graph data only for African countries.

Map regions have the following elements:

Open the StatPlanet Data Editor and in the worksheport” go all the way to the last country agth
end of row 2.

In the empty cells in row 2, add the names of ywew data types (for example “Sub-Saharan Africa”).

Press the buttoBave data The names of your new data types have now bededad

Name(col. 1} The names of the map regions you wish to defingou wish to group regions into a
sub-menu, insert the name of your sub-menu justdiky region name. Then for the subsequent region
names below, add >’ if you wish to include thenthis sub-menu (the principle is the same as wi¢h t
categorization of indicators). In the example beltMy sub-menu” is the name of your sub-menu, and
the symbol “>” is used to define the two regiond&included in this sub-menu:

Region 1

Region 2

My sub-menu

> Region 3 (inside sub-menu)
> Region 4 (inside sub-menu)
Region 5 (not inside sub-menu)
etc.

Map coordinates(col. 2-4) The X and Y coordinates and ZOOM level for thered regions. To get
these coordinates, open your map in StatPlanetamah into the map area you wish to add (e.g. zoon
into Africa and click and drag the map so Afridésfthe screen). Once you are satisfied with thp ma
position, right-click anywhere in StatPlanet ankkse'copy map coordinates'. Go back to the Excel
sheet ‘Map regions’, and ‘paste’ the coordinatethencorresponding row for the region.

=

Color (col. 5 - optional) The color for each region which will be used téocohe bubbles in the scatter
plot graph. It is also possible to color the baarthising the region colors. A region colors needse
specified as a “hex color”, for example “0x0000F&t blue.

Link (col. 6 — optional, StatPlanet Plus onlinsert a link or URL, for example to link a mapmawith
another copy of StatPlanet with this map embedded.

Codes(col. 7 onwards)Columns 7 onwards contain the codes for the castr map areas in each
region (these are ISO3 country codes for the wowg version of StatPlanet). The codes for each
country or map area can be found in the top rothefsheet ‘Data’. To add countries or map areas to

24




custom region, add the codes in columns 7 onwaitt®ut leaving any empty cells between them.

6.5 Adding data directly (with or without Excel)

You can edit the data filefata.csvandsettings.cswirectly without using the Excel-based Data Edifidrese
two files can be edited using any spreadsheet aodtw

The data needs to be saved as a CSV (‘comma sapaedties’) file.

6.6 Language and translation

StatPlanet is available in French, Spanish, Gerahasa Indonesia (courtesy of the Government of
Indonesia) and Dutch. Select the language you teisise in the sheet ‘Settings’. To edit any oftth@slations
or create a new translation, see the Excel sheat-Translations’.

25




7. REDUCING THE DOWNLOAD SIZE OF YOUR WEB APPLICATION

StatPlanet is optimized to keep the file size aallsas possible. The following is a list of measunénich can
be implemented to reduce the file size of yourratéve maps even further:

1.

ZIP the data file(s): this can reduce the file size by as much as 7€epérStatPlanet will automatically
detect whether the data is inside a ZIP or not.fdrae of the ZIP archive needs to be “data.zipyoli
have multiple data files (StatPlanet Plus onlygsthcan also be zipped.

Decimal places:file sizes can often be reduced by around 50 pérEgou round numbers to two or
three decimal places. A macro is included in tregF8anet Data Editor for rounding all the numbaers i
the Excel sheet ‘Import’ to two decimal places. Tin&cro is called “RoundToDecimalPlaces” and can
be adjusted as required.

CSV file format: the CSV file format was chosen because it keepsitte of the data file to an absolut
minimum, because data values are separated ordgrhynas. In comparison, XML files are often
several times bigger when containing the equivaembunt of data.

No duplication: indicator names and descriptions do not need ttupécated in the data file. If you are

using the StatPlanet Data Editor, any duplicatecatdr names will automatically be replaced witha th
‘- symbol. Indicator names only need to be indéchfor the very first year of a data series. For
indicator descriptions, duplication can also bei@®d — see the section “Indicator Description” fimore
information.

Reduce map size (shapefile version onlythe maps themselves are often much bigger thaRISteet
and the data files combined. GIS software can bd tsreduce the level of map detail. There is also
free utility called MapShaperwww.mapshaper.orgHowever, when using MapShaper the exported
map still needs to be imported and then exportethagsing GIS software to make it compatible with
StatPlanet.
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8. DESIGNING A MAP USING ADOBE FLASH

To create custom interactive maps using StatPlgoatneed the following:
» StatPlanet Map Maker
* Adobe Flash CS4 or higher

* A map file in vector format, either Adobe lllustoat(.ai), FreeHand (.fh*, .ft*), or Adobe Flashw.
(See also: Converting images into a suitable veotonat)

For an example of what the final result could |di&k, see the file 'map_example.fla' (shown below).

StatPlanet Example Map of Kenya (map_example.fla)

| StatPlanetz.10.fla | map.fla* [
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8.1 Using the map template

To prepare the map so it can be loaded into Sta¢Blsiou need to open theap template- 'map.fla’ - which is
in the 'StatPlanet_Custom_Map' folder. This filatains the following four layers:

Map layer: This layer will contain the map shapeg (regions or provinces).

Borders layer: This layer will contain the map bensd

(Note: since version 2.3, map text labels are aatmally generated and no longer need to be addeuliaily).

Step 1. Map layer

Before inserting your map into the map templatep(fite), it may be easiest to edit it first in a ndacument.

Open a new document (File -> New).
Import your map. Go to File -> Import to Stage, aetect your map file.

Once the map is imported, select and remove tralslgbu do not need such as text labels, roads, et
(Click outside the selected area to deselecten tlick on any of the details you wish to remond a
press delete).

Select all (Edit -> Select all).

Break apart the shapes of your map by pressing GBRbr using the menu: Modify -> Break Apart).
You may need to repeat this several times untiktieges cannot be broken apart any further.

o What to do if a rectangle appears which covers youmap:
In some cases a rectangle may suddenly appear wiaglpreviously hidden from view. If this
is the case, click anywhere outside the selectiea t deselect it. Then click on the rectangle
and press 'delete’. You should now see the map.gd¥ote: if you did 'Break Apart' one too
many times, the rectangle and your map merge,@chap disappears. You will need to go
back and redo this, and remove the rectangle whaestill a seperate shape).

Select all (Edit -> Select all).
Copy the map (Edit -> Copy).
Open the map template (map.fla).

Select the first frame in the timeline in the layrmap’ (normally in the top of the screen, see #ilso
example screenshot above - the first frame lodesdiwhite rectangle with a circle in it).

Paste your map (Edit -> Paste in Place).

Double-click on the map borders. This should nolyreglect all the borders in one go. Otherwisedhol
down the Shift key and double click on the remairtsorders. Once you have all your borders selecte
change the border thickness in the Properties P&@tiek on the drop-down which currently has 'Solid
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Step 2. Borders layer

selected, and change this to ‘hairline'. If thedbos are different colors, make them one color by
clicking in the color selection box. Select anyardfor example black).

Now select the different shapes of your map onertgyand convert each of them into a Movie Clip. T
convert them into a Movie Clip, press F8 (or usertienu: Modify -> Convert to Symbol).

(@)

o What to do if shapes do not separate properly:
In some cases the shapes of your map may not kpeeated properly, because the borders are
not properly joined up. You can either draw exigtoorders to make them join up, or draw them
in using the pencil tool. To join them up, you @dick on the edge of one of the lines just at the
point where it does not join up, and drag the tm&here it should join. Alternatively, click on
the Pencil Tool in the Drawing Toolbar (normally thre left). Then draw in the lines where the
gap exists. If this is done correctly, the shapesikl now be separated.

o What to do if your map consists only of map boundaes, not shapes:
If your map consists only of map boundaries or bosdyou can fill the boundaries with the
'Paint Bucket Tool'. Select the 'Paint Bucket Toothe Drawing Toolbar (normally on the left)
and click within the map boundaries you wish tb ftlcan be filled using any color.

Assign an instance name to each of the movie clips.instance name can be entered in the properties
panel which is normally below the stage (see disceikample screenshot above).

The instance name cannot contain spaces. Thergfmrenay wish to assign a 'code’ rather than the
actual name. The actual name can be defined tateeiStatPlanet Data Editor, where it can include
spaces.

The size / position of the map can be adjustedatea stage in the Data Editor (in the Excel sheet
'Settings’).

Once you have created the map Movie Clips, youddrsrmay have become hidden from view. To
make them appear again, you need to select athfi|eMovie Clips you just created one by one, while
holding the SHIFT key. Once you have selectedfathem, select Edit -> Cut. You should see the map
boundaries reappear.

Now select the map borders by double-clicking oy @art of them. This should normally select all the
borders in one go. Otherwise, hold down the SHIEY &nd double click on any of the borders which
are not yet selected. Once you have selectedeabldiders, press CTRL + G (or use the menu: Modify
> Group).

Once you have grouped all the map borders, yoplzae all the Movie Clips back again. Select Edit -
Paste in Place. While the Movie Clips are stiles&td, right-click on any of them, and from the pop
menu select Arrange -> Send to Back. Now your n@gédrs should appear on top of the map.
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Click anywhere outside the selection area to des#lelhen click somewhere on the map borderss Th
requires some precision so that you do not acadlgrdlick on one of the map Movie Clips instead.
Once you have selected the borders, go to Editt>Then select the first frame in the 'bordengtan
the timeline panel, and go to Edit -> Paste in €lac

While the borders are still selected, turn thera mMovie Clip by pressing F8 (or using the menu:
Modfiy -> Convert to Symbol).

In the Movie Clip properties panel below the stagiee the Borders Movie Clip the instance name:
borders.

Step 3. Publish your map file

Once your map is ready, publish the file (File tbish).

Go to the directory containing map.fla. You shosé@ a new file, 'map.swf'. Copy and paste this file
into the directory “Web” (for the online version $fatPlanet), replacing the existing 'map.swf'".

Step 4. Linking the map in StatPlanet Data Editor

In StatPlanet_data_editor.xls, first insert thal'reames’ of your map regions, and then the ‘igstan
names' or codes which you used in the map file (fadp

In the sheet 'Import’, replace the example namégfware Kenya province names) with your own
names, in the order that you wish. Then press titie 'Save data'.

Go to the sheet 'Data’ (see the sheet names bottan left of Excel). In the top row you shoulese
list of example codes (CEN, COA, EAS, etc.). Remibvse codes and replace them with the codes
(instance names) you have used in your map fileyBmould be in the same order as the map names
the sheet 'Import'. (in the example, the order apmegions in the sheet 'Import' is Central, Coast,
Eastern...etc., and the corresponding codes ishtbet 'Data’ are CEN, COA, EAS, etc.).

Go back to the sheet 'Import' and insert the datgdur map regions here. You can also use theoittnp
data' button to import your data from a file autdicadly. If the import fails, it is most likely bazise the
names of map regions in the file you are importingld not be recognized. In that case, you need to
add them in the sheet 'Import names'. See alsseitteon on “Importing data”.

Once the data has been added, press the buttendatv.

Go back to the directory Offline and open StatPi@xe to see your map in action. Or go to the
directory Web and open the file StatPlanet.htndgen it in a web-browser. If you wish to publishuyo
interactive map on a website, copy and paste theents of the folder 'Web' to the web-server. Sse a
the file 'StatPlanet_small.html' for an exampldoiv the map can be integrated into an existing web-

page.
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Step 5. Map positioning: (optional)

To change the position and size of the map, moeentbuse to the bottom-right of the screen to seeniyp
zoom controls:

« Zoom: You can zoom in and out of the map using therzo® and 'zoom out' buttons, or by dragging
the zoom slider up or down. If your mouse has albatheel, you can also use this to zoom in and out
« Moving the map: click and drag the map with the mouse to move & hew position.

Once the map is in the right position, right-clexkd select 'Copy map coordinates'. In the StatPRaka
Editor, go to the sheet 'Map regions’, select glebelow 'X'. Then paste the coordinates here.

Step 6. Text labels: (optional)

8.  To hide/show the text labels for the map, click®now text labels’ in the StatPlanet Data Editdre@t
Import, below the Save button).

9.  Click on “Save data” and open StatPlanet to seedhdts. It is likely that the position of someatirof
the text labels will need some adjusting.

10. To adjust the position of the text labels, righticlanywhere in StatPlanet and select ‘Move telxéls!
in the menu. Click on any of the text labels togditeem to a new position.

11.  Once you have finished moving the text labelditraick and select ‘Copy text label coordinates’ i
the menu.

12. In StatPlanet, go to the sheet ‘Settings’. Seleetcell next to ‘“Text label coordinates’, and pakte
coordinates here. (You may also wish to modify p#edtings in this sheet, such as the text fora. iz

13. Click on ‘Save settings’ (or alternatively, ‘Savata in the Import data screen). The coordinate® ha
now been saved for when you next open StatPlanet.

14. In the sheet ‘Settings’, you can also change amfdhtisettings such as the font size of the texdltab
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8.2 Converting images into a suitable vector format

Converting a GIS shape file (.SHP) into a vector fonat recognized by Adobe Flash

Maps for GIS (Geographic Information Systems) amamonly exchanged as ESRI Shapefiles. Such files ce
be converted into Adobe lllustrator vector filesngssoftware such as ArcGIS or MAPublisher. Connerthe
file in ArcGIS can be done as follows: select 'FieExport Map'. In the 'Save as' drop-down sékktas the
file format. Then click on 'Save'. Adobe lllustrafdl) files can be imported directly into Flash.

You may also wish to open the image first in Addhestrator, export the image as a Flash SWF &l
import the SWF into Flash. Importing an SWF filersdimes leads to better results than importing bfilé

If you do not have access to such software, yolddoy a free Shapefile to SVG converter calledZdyy. See
below for converting an SVG image into a formatoigruzed by Flash.

Converting a vector image (such as SVG) into a vemtformat recognized by Adobe Flash

Use Adobe lllustrator to open the file, and thepakthe file into the right format. It seems thta¢ best results
are achieved when using Adobe lllustrator to exp@timage as an Adobe Flash SWF, then importiag th
SWEF into Flash.

If you do not have Adobe lllustrator, you could tgnverting the file using the free vector grapladgor
Inkscape. You may also wish to try this free SVGZIS¥gnversion tool.

Converting a Bitmap image into a vector format (e.gGIF, JPG, PNG, BMP)

It is impossible to perfectly convert a Bitmap ireagto a vector one, but with some experimentatio
possible to achieve good results. To convert a &8itmmage, first import it into Flash (File -> Impdoo Stage).
Then select the image, and select Modify -> Bitrraprace Bitmap.

You will need to experiment with the following teasettings to get optimal results:

» Color threshold: Increase this value to decrease the number ofoidhe resulting vector image.
(When comparing two pixels, if the difference ie tRGB color values is less than the color threshold
specified here, they are considered to be the saioe).

* Minimum area: Increase this value to decrease the number okshapghe resulting vector image. Thi
is the number of surrounding pixels considered wdmesigning a color to a pixel.

» Curve fit: How smoothly the outlines will be drawn.
» Corner threshold: Select how many corners you wish to keep.

The following values illustrate what settings te uflsyou wish to create a vector that most closesembles the
original bitmap. However, the settings below arerecommended due to the large number of shapatedie
These settings may also cause the Flash softwaragb.

e Color Threshold: 10
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Minimum Area: 1 pixel
Curve Fit: Pixels

Corner Threshold: Many Corners

Manually tracing the outlines

If automatically tracing the image does not leatheadesired results, you can draw the outlinelsamnd.
Unless your map if quite large or complex, thiaa$ necessarily a very long process. It can be dgrfellows:

1.
2.

Convert the map into a Movie Clip (Modify -> Convéy Symbol).

In the properties panel below, click on the 'Cativdp-down and select 'Alpha’. Change the value to
around '30%' (so you can still see the outlinethefmap clearly).

Insert a new layer (Insert -> Timeline -> Layer).

Select the Line tool for the Drawing Toolbar, amdwd the outlines in this new layer following the
outlines of the map in the layer below. Make shit all the lines are touching. To draw a curust fi
draw a straight line. Then, click somewhere inrthiddle of the line, and drag it one way or another.

Select the Paint Bucket tool and click inside thedlers to create your map regions. If it does natky
the borders you have drawn are probably not togcldoom in to see if you can detect the breach.

Remove the bottom layer containing your bitmap iemag

Follow the steps above to convert your map forins&tatPlanet.
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